INVITE sip:12123527500@64.113.255.83:5060 SIP/2.0
From: <sip:6469270103@64.113.255.83:5060;transport=UDP>;tag=4aa2358-7f000001-13c4-995-3ae32701-995
copy of config
! ADTRAN, Inc. OS version R11.4.5.E
! Boot ROM version 14.05.00.SA
! Platform: Total Access 908e (2nd Gen), part number
4242908L5
! Serial number CFG0804958
!
!
hostname "SV8100-SIP_2WAN"
enable password password
!
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
!
name-server 8.8.8.8 8.8.4.4
!
ip local policy route-map Failover
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "SV8100-SIP_2WAN" password "@SV8100-SIP_2WAN!#"
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
probe Failover icmp-echo
destination 8.8.8.8
source-address 8.12.98.250
period 1
tolerance consecutive fail 5 pass 5
no shutdown
!
track Failover
snmp trap state-change
test if probe Failover
no shutdown
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 8.12.98.250 255.255.255.248
no ip proxy-arp
ip address 10.10.10.1 255.255.255.0 secondary
media-gateway ip primary
no awcp
no shutdown
!
!
interface eth 0/2
ip address 68.165.253.62 255.255.255.248
no ip proxy-arp
media-gateway ip primary
no awcp
no shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 0/4
tdm-group 1 timeslots 1-24 speed 64
shutdown
!
!
interface pri 1
description pri 1
role network b-channel-restarts enable
isdn name-delivery display
connect t1 0/3 tdm-group 1
digits-transferred 4
no shutdown
!
interface pri 2
description pri 2
role user
connect t1 0/4 tdm-group 1
no shutdown
!
!
interface fxs 0/1
shutdown
!
interface fxs 0/2
shutdown
!
interface fxs 0/3
shutdown
!
interface fxs 0/4
shutdown
!
interface fxs 0/5
shutdown
!
interface fxs 0/6
shutdown
!
interface fxs 0/7
shutdown
!
interface fxs 0/8
shutdown
!
!
interface fxo 0/0
shutdown
!
!
isdn-group 1
!
!
isdn-group 2
connect pri 1
!
!
isdn-group 3
connect pri 2
!
!
!
!
timing-source t1 0/4
!
route-map Failover permit 1
description "Failover"
match ip address Failover
set ip next-hop 8.12.98.249
set interface null 0
!
!
!
!
ip access-list standard SIP
permit 64.113.255.80 0.0.0.15
permit 76.9.246.224 0.0.0.15
!
!
ip access-list extended Failover
permit icmp any hostname 8.8.8.8
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 8.12.98.249 track Failover
ip route 0.0.0.0 0.0.0.0 68.165.253.57 10
!
ssh-server 2222
no tftp server
no tftp server overwrite
no http server
http secure-server 60443
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
!
!
!
!
voice codec-list Generic
codec g711ulaw
codec g711alaw
codec g722
!
!
voice trunk-list CarrierPRI
trunk T03
!
voice trunk-list PBX
trunk T02
!
voice trunk-list SIP
trunk T01
!
!
voice trunk T01 type sip
description "DynaCloud"
match dnis "NXX-NXX-XXXX" substitute "1NXX-NXX-XXXX"
sip-server primary 64.113.255.83
domain "8.12.98.250"
codec-list Generic both
!
voice trunk T02 type isdn
description "PBX"
resource-selection linear ascending
caller-id-override number-inbound 6469270103 if-no-cpn
caller-id-override emergency-outbound 6469270103
connect isdn-group 2
no early-cut-through
modem-passthrough
t38
t38 redundancy high-speed 3
t38 redundancy low-speed 2
t38 max-rate 9600
rtp delay-mode adaptive
codec-list Generic
!
voice trunk T03 type isdn
description "CarrierPRI"
resource-selection linear ascending
connect isdn-group 3
modem-passthrough
t38
t38 redundancy high-speed 3
t38 redundancy low-speed 2
t38 max-rate 9600
rtp delay-mode adaptive
!
!
voice grouped-trunk VOIPCARRIER
trunk T01
accept $ cost 0
permit list PBX
!deny all other trunks
!deny all other ani
!
!
voice grouped-trunk PBX
trunk T02
accept $ cost 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
shutdown
line ssh 0 4
login local-userlist
no shutdown
!
sntp server time.nist.gov
!
ntp source ethernet 0/1
!
!
!
end !
The From Header is exactly as it should be according to your config.
The line:
sip-server primary 64.113.255.83
Tells it to insert 64.113.255.83 after @ in the From header.
Normally what you actually want is a domain name like voip.evolveip.net. So you set:
sip-server primary voip.evolveip.net
The INVITE will show the actual IP after its resolved by a DNS query and the From header will show @voip.evolveip.net.
lazarb,
That is the default sip grammar for the 908. If you want, you can add the following configuration and it will do what you are wanting...
ip sip grammar from host local
____________________________________________________________
There are quite a few different options that you can reconfigure:
tac-ta924-1(config)#ip sip grammar
alert-info - Configure Alert-Info format
default-privacy - Configure default Privacy header format
from - Configure From header format
p-asserted-identity - Configure P-Asserted-Identity header format
proxy-require - Configure Proxy-Require header format
refer-to - Configure source for refer-to header
request-uri - Configure Request-URI
require - Configure Require header format
restricted-privacy - Configure restricted Privacy header format
supported - Configure Supported format
to - Configure To header format
user-agent - Configure User-Agent header format