Hello,
This is my first time trying to configure an Adtran gateway. I'm trying to configure all FXS ports in the gateway to connect fax machines which are used only for outbound faxing, all of them have the same outbound DID. The other end of the gateway is a SIP trunk that goes to an Asterisk server, which handles the calls from the gateway.
I already have a different brand gateway doing this task in production that I would like to retire. This gateway is configured so that it doesn't have to register every single FXS port as a user in Asterisk. I would like to accomplish the same with the Adtran unit: take any calls from the FXS ports and send them through the SIP trunk to Asterisk, no registration or authentication.
Below is the configuration I have. When I try to make a call, I get a busy and nothing reaches the Asterisk server. Asterisk shows the trunk to be up.
Any help is appreciated.
! ADTRAN, Inc. OS version A4.11.00.E
! Boot ROM version 14.04.00
! Platform: Total Access 924 (2nd Gen), part number 4212924L1
!
hostname "FXSGW1"
enable password
!
ip subnet-zero
ip classless
ip routing
!
ip domain-proxy
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password "password"
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
no dot11ap access-point-control
!
interface eth 0/1
ip address 10.3.4.25 255.255.252.0
media-gateway ip primary
no shutdown
!
interface t1 0/1
no shutdown
!
interface t1 0/2
shutdown
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxs 0/9
no shutdown
!
interface fxs 0/10
no shutdown
!
interface fxs 0/11
no shutdown
!
interface fxs 0/12
no shutdown
!
interface fxs 0/13
no shutdown
!
interface fxs 0/14
no shutdown
!
interface fxs 0/15
no shutdown
!
interface fxs 0/16
no shutdown
!
interface fxs 0/17
no shutdown
!
interface fxs 0/18
no shutdown
!
interface fxs 0/19
no shutdown
!
interface fxs 0/20
no shutdown
!
interface fxs 0/21
no shutdown
!
interface fxs 0/22
no shutdown
!
interface fxs 0/23
no shutdown
!
interface fxs 0/24
no shutdown
!
ip route 0.0.0.0 0.0.0.0 10.3.4.1 100
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
ip sip
ip sip udp 5060
no ip sip tcp
!
voice feature-mode network
voice forward-mode network
!
voice codec-list Codecs
codec g711ulaw
!
voice trunk T01 type sip
description "FAX lines"
sip-server primary 10.3.4.31
sip-server secondary 10.3.4.30
outbound-proxy primary 10.3.4.31
outbound-proxy secondary 10.3.4.30
codec-group Codecs
!
voice grouped-trunk G01
trunk T01
accept $ cost 0
!
voice user 7730000000
connect fxs 0/1
password "1234"
no special-ring-cadences
message-waiting lamp-only
sip-identity 7730000000 T01
sip-authentication password "1234"
!
line con 0
no login
!
line telnet 0 4
login
password password
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
end
Because your FXS lines are all going to use the same DID and are outbound only, you can assign a bogus extension number to each of them and use caller-id-override for the ANI.
You don't really need SIP identity in this scenario.
voice user 11111
connect fxs 0/1
password "1234"
no special-ring-cadences
caller-id-override external-number 7730000000
no message-waiting
no echo-cancellation
no call-waiting
modem-passthrough
voice user 11112
connect fxs 0/2
password "1234"
no special-ring-cadences
caller-id-override external-number 7730000000
no message-waiting
no echo-cancellation
no call-waiting
modem-passthrough
voice user 11113
connect fxs 0/3
password "1234"
no special-ring-cadences
caller-id-override external-number 7730000000
no message-waiting
no echo-cancellation
no call-waiting
modem-passthrough
...and so on
I would put a more specific accept pattern on the grouped-trunk to minimize post-dial delay.
voice grouped-trunk G01
trunk T01
accept NXX-XXXX cost 0
accept 1-NXX-NXX-XXXX cost 0
accept 011-$ cost 0
accept 411 cost 0
accept 611 cost 0
accept 911 cost 0
reject 976-XXXX
reject 1-900-NXX-XXXX
reject 1-976-NXX-XXXX
If the calls fail to hit the asterisk server at all, turn on debugging and try to place a call, then paste the output here.
debug voice verbose
debug sip stack messages
Because your FXS lines are all going to use the same DID and are outbound only, you can assign a bogus extension number to each of them and use caller-id-override for the ANI.
You don't really need SIP identity in this scenario.
voice user 11111
connect fxs 0/1
password "1234"
no special-ring-cadences
caller-id-override external-number 7730000000
no message-waiting
no echo-cancellation
no call-waiting
modem-passthrough
voice user 11112
connect fxs 0/2
password "1234"
no special-ring-cadences
caller-id-override external-number 7730000000
no message-waiting
no echo-cancellation
no call-waiting
modem-passthrough
voice user 11113
connect fxs 0/3
password "1234"
no special-ring-cadences
caller-id-override external-number 7730000000
no message-waiting
no echo-cancellation
no call-waiting
modem-passthrough
...and so on
I would put a more specific accept pattern on the grouped-trunk to minimize post-dial delay.
voice grouped-trunk G01
trunk T01
accept NXX-XXXX cost 0
accept 1-NXX-NXX-XXXX cost 0
accept 011-$ cost 0
accept 411 cost 0
accept 611 cost 0
accept 911 cost 0
reject 976-XXXX
reject 1-900-NXX-XXXX
reject 1-976-NXX-XXXX
If the calls fail to hit the asterisk server at all, turn on debugging and try to place a call, then paste the output here.
debug voice verbose
debug sip stack messages
Jo.user1,
Thanks for posting! I noticed that you had not replied to the post above, so I just wanted to check back with you and see if you have any further questions. Just let us know with a reply if you have any further questions or you have an update on the situation.
Thanks!
David
Thanks for the reply. It was helpful.
The command: caller-id-override external-number 7730000000 wouldn't set the outbound CID. I had to enforce that at the Asterisk server.
All is good now.
Thanks.