I'm setting up my first SIP Trunk to T1 PRI/PBX connection and I can pass SIP through the VoIP Innovations endpoint to the Adtran but I don't seem to be having a lot of luck after that. I attempted to diligently follow a few sample configs I found throughout the support forums and on the internet. My customer also just threw me a bit of a curve ball in that they would like us to only pass the last 5 digits of the phone number to them. I'm having trouble pulling up that kind of information easily and was wondering if someone could take a look at my config file and then point me to the right information, thanks!
!
!
! ADTRAN, Inc. OS version A4.11.00.E
! Boot ROM version 14.04.00
! Platform: Total Access 916 (2nd Gen), part number 4212916L1
! Serial number CFG1326470
!
!
hostname "TA916"
enable password ############
!
!
ip subnet-zero
ip classless
ip default-gateway 23.xxx.xxx.xxx
ip routing
!
!
ip name-server 204.xxx.xxx.xxx 204.xxx.xxx.xxx
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "######" password "#########"
username "######" password "#########"
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 23.xxx.xxx.xxx 255.255.255.252
media-gateway ip primary
no awcp
no shutdown
!
!
!
!
interface t1 0/1
no shutdown
!
interface t1 0/2
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description PRI to PBX
isdn name-delivery setup
connect t1 0/2 tdm-group 1
role network b-channel-restarts disable
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxs 0/9
no shutdown
!
interface fxs 0/10
no shutdown
!
interface fxs 0/11
no shutdown
!
interface fxs 0/12
no shutdown
!
interface fxs 0/13
no shutdown
!
interface fxs 0/14
no shutdown
!
interface fxs 0/15
no shutdown
!
interface fxs 0/16
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 23.xxx.xxx.xxx
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-XXXX
voice dial-plan 3 international 011-$
voice dial-plan 4 long-distance 1-NXX-NXX-XXXX
!
!
!
!
voice codec-list "PRI to PBX"
codec g729
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "vi1"
sip-server primary 64.136.174.30
codec-group "PRI to PBX"
!
voice trunk T02 type sip
description "vi2"
sip-server primary 64.136.174.35
!
voice trunk T03 type isdn
description "PRI to PBX"
resource-selection circular descending
connect isdn-group 1
modem-passthrough
t38
rtp delay-mode adaptive
rtp dtmf-relay inband
codec-group "PRI to PBX"
!
!
voice grouped-trunk "PRI TO PBX"
description "PRI to PBX"
trunk T03
accept NXX-XXXX cost 0
accept 1-NXX-NXX-XXXX cost 0
accept 011-$ cost 0
accept 911 cost 0
accept 1-800-NXX-XXXX cost 0
accept 1-888-NXX-XXXX cost 0
accept 1-877-NXX-XXXX cost 0
accept 1-866-NXX-XXXX cost 0
accept 1-855-NXX-XXXX cost 0
accept 411 cost 0
accept 611 cost 0
reject 976-XXXX
reject 1-900-NXX-XXXX
reject 1-976-NXX-XXXX
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
!
!
!
end
Looks like we had everything going nicely other than the DNIS substitute on the two SIP trunks. This was the final config that we got working...pretty much figured out all my own issues!
!
!
! ADTRAN, Inc. OS version A4.11.00.E
! Boot ROM version 14.04.00
! Platform: Total Access 916 (2nd Gen), part number 4212916L1
! Serial number CFG1326470
!
!
hostname "xxxxxxxxxxxxxxx"
enable password xxxxxxxxxxxxxxxxx
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip default-gateway 23.xxx.xxx.xxx
ip routing
!
!
ip name-server 204.xxx.xxx.xxx 204.xxx.xxx.xxx
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password "xxxxxxxxxxx"
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 23.xxx.xxx.xxx 255.255.255.252
media-gateway ip primary
no awcp
no shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description PRI to PBX
isdn name-delivery setup
connect t1 0/2 tdm-group 1
role network b-channel-restarts disable
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxs 0/9
no shutdown
!
interface fxs 0/10
no shutdown
!
interface fxs 0/11
no shutdown
!
interface fxs 0/12
no shutdown
!
interface fxs 0/13
no shutdown
!
interface fxs 0/14
no shutdown
!
interface fxs 0/15
no shutdown
!
interface fxs 0/16
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 23.xxx.xxx.xxx
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-XXXX
voice dial-plan 3 international 011-$
voice dial-plan 4 long-distance 1-NXX-NXX-XXXX
!
!
!
!
voice codec-list "PRI to PBX"
codec g729
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "vi1"
match dnis "NXX-XXXX" substitute "1-607-NXX-XXXX" name "local"
sip-server primary 64.136.174.30
codec-group "PRI to PBX"
!
voice trunk T02 type sip
description "vi2"
match dnis "NXX-XXXX" substitute "1-607-NXX-XXXX" name "local"
sip-server primary 64.136.174.35
!
voice trunk T03 type isdn
description "PRI to PBX"
resource-selection circular descending
connect isdn-group 1
modem-passthrough
t38
rtp delay-mode adaptive
rtp dtmf-relay inband
codec-group "PRI to PBX"
!
!
voice grouped-trunk "PRI TO PBX"
description "PRI to PBX"
trunk T03
accept $ cost 0
!
!
voice grouped-trunk "SIP VI"
description "SIP Trunk"
trunk T01
trunk T02
accept $ cost 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login
password xxxxxxxxx
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
ntp source ethernet 0/1
ntp server _INTERNAL_NTP_SERVER_ version 3 source ethernet 0/1 prefer
!
!
!
end
but if anyone comes across this and finds anything that may come up as a future issue or has any general comments or tips, just post away!
I think I figure one part of this. I set 'digits-tranferred 5' but it still displays as ALL in the PRI settings. Is that due to a display limitation in the GUI or will it only do 4/7/etc? Still looking for assistance with overall config, thanks!
Looks like we had everything going nicely other than the DNIS substitute on the two SIP trunks. This was the final config that we got working...pretty much figured out all my own issues!
!
!
! ADTRAN, Inc. OS version A4.11.00.E
! Boot ROM version 14.04.00
! Platform: Total Access 916 (2nd Gen), part number 4212916L1
! Serial number CFG1326470
!
!
hostname "xxxxxxxxxxxxxxx"
enable password xxxxxxxxxxxxxxxxx
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip default-gateway 23.xxx.xxx.xxx
ip routing
!
!
ip name-server 204.xxx.xxx.xxx 204.xxx.xxx.xxx
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password "xxxxxxxxxxx"
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 23.xxx.xxx.xxx 255.255.255.252
media-gateway ip primary
no awcp
no shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description PRI to PBX
isdn name-delivery setup
connect t1 0/2 tdm-group 1
role network b-channel-restarts disable
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxs 0/9
no shutdown
!
interface fxs 0/10
no shutdown
!
interface fxs 0/11
no shutdown
!
interface fxs 0/12
no shutdown
!
interface fxs 0/13
no shutdown
!
interface fxs 0/14
no shutdown
!
interface fxs 0/15
no shutdown
!
interface fxs 0/16
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 23.xxx.xxx.xxx
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-XXXX
voice dial-plan 3 international 011-$
voice dial-plan 4 long-distance 1-NXX-NXX-XXXX
!
!
!
!
voice codec-list "PRI to PBX"
codec g729
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "vi1"
match dnis "NXX-XXXX" substitute "1-607-NXX-XXXX" name "local"
sip-server primary 64.136.174.30
codec-group "PRI to PBX"
!
voice trunk T02 type sip
description "vi2"
match dnis "NXX-XXXX" substitute "1-607-NXX-XXXX" name "local"
sip-server primary 64.136.174.35
!
voice trunk T03 type isdn
description "PRI to PBX"
resource-selection circular descending
connect isdn-group 1
modem-passthrough
t38
rtp delay-mode adaptive
rtp dtmf-relay inband
codec-group "PRI to PBX"
!
!
voice grouped-trunk "PRI TO PBX"
description "PRI to PBX"
trunk T03
accept $ cost 0
!
!
voice grouped-trunk "SIP VI"
description "SIP Trunk"
trunk T01
trunk T02
accept $ cost 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login
password xxxxxxxxx
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
ntp source ethernet 0/1
ntp server _INTERNAL_NTP_SERVER_ version 3 source ethernet 0/1 prefer
!
!
!
end
but if anyone comes across this and finds anything that may come up as a future issue or has any general comments or tips, just post away!