Looking for help with setting up our TA908 to provide SIP - PRI. Have the SIP side responding to Options pkts from my SBC and Binding is clean in my Metaswitch. The PRI is up to my Exfo test set clean.
I can complete and inbound call from cell phone to Exfo but I get no audio. an outbound call from Exfo dies at the PRI - SIP handoff. I know I have to be missing something between the two services within the 908. Thanks for the help...
hostname "TA908"
no enable password
!
!
ip subnet-zero
ip classless
ip routing
!
!
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 172.XX.XX.X 255.255.255.248
media-gateway ip primary
no shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
description PRI to PBX
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description PRI to PBX
isdn name-delivery setup
connect t1 0/2 tdm-group 1
role network b-channel-restarts disable
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
timing-source t1 0/2
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 172.XX.XX.X
!
no ip tftp server
no ip tftp server overwrite
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
!
!
!
voice codec-list trunk
codec g729
codec g711ulaw
!
!
!
voice trunk T01 type sip
outbound-proxy primary 172.XX.X.X
codec-group trunk
!
voice trunk T02 type isdn
description "PRI to PBX"
resource-selection linear ascending
connect isdn-group 1
rtp delay-mode adaptive
!
!
voice grouped-trunk SIP
trunk T01
accept $ cost 0
!
!
voice grouped-trunk PRI
trunk T02
accept $ cost 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
!
!
!
end
TA908#
Can you do a packet capture? I've seen RTP Audio issues are generally a IP / NAT issue. Config appears to be ok, not sure which generation you're running, but I always run my PRI's off T-1 interface 3 or 4.
The config only shows two t1 interfaces, which makes me think this is a non- e TA900 unit. T1 0/2 would be the only available interface to run a PRI.
I'd be interested in seeing the configuration you've got on the Metaswitch, in order to get a full grasp of how things are programmed. It looks like you're connected on the same, local subnet? (172.xxx.xxx.xxx)
Here's the TA900 configuration I use, well, the important parts.
voice trunk T00 type sip
description "SBC1 - SIP to PRI/POTS"
sip-server primary <metaswitch_IP>
registrar primary <metaswitch_IP>
register <sip_username> auth-name <sip_username> password <sip_password>
authentication username <sip_username> password <sip_password>
interface t1 <interface>
tdm-group 1 timeslots 1-24 speed 64
codec-group G711u
no shutdown
exit
interface pri 1
isdn name-delivery setup
connect t1 <interface> tdm-group 1
digits-transferred <0,3,4,7,all>
no shutdown
exit
isdn-group 1
connect pri 1
exit
voice trunk T01 type isdn
description “PBX - SIP to PRI”
resource-selection linear descending
connect isdn-group 1
rtp delay-mode adaptive
exit
voice grouped-trunk PRI
trunk T01
accept $
exit
write
exit
ftwrobert, thanks for the reply....we built a /29 network for testing this service. The contact IP 172.22.24.X and outside interface of my Perimeta SBC 172.22.1.X which in turn points to the inside CFS 172.20.1.XXX.
Name 901TEST
Usage Subscriber
LearnsContactDetails False
DelegatedManagementGroup Ems.0.default/MVConfigDBConn/DelegatedManagementGroupContainer/DelegatedManagementGroup.0 //default
UseDNForIdentification True
SIPAuthenticationRequired False
SIPDomainName sbc.imon.net
IPAddressMatchRequired False
ContactIPAddress 172.22.24.X
ContactIPPort 5060
SupportedIncomingTrunkGroupParameterType None
TrunkGroupParameterTypeOnOutgoingMessages None
ProxyIPAddress 172.20.1.XXX
ProxyIPPort 5060
TransportProtocol UDP
MediaGatewayModel ../MediaGatewayModelContainer/MediaGatewayModel.133 //Remote Media Gateway Model "SIP Trunk Business"
NetworkNode Use default
NetworkNodeDefaultValue None
NetworkNodeSpecificValue None
SIPBindingLocation None
ESAProtectionDomain None
Trusted True
UseCallerNameProvidedBySIPDevice False
PlayAnnouncementsWhenErrorConditionsOccur True
UseStaticNATMapping False
MaximumCallAppearances 10
MaximumConcurrentHighBandwidthCallAppearancesAllowed 0
PollPeerDevice True
PollingInterval 30
ConcurrentNumberOfCallAppearancesInUse 0
ConcurrentNumberOfHighBandwidthCallAppearancesInUse 0
DeactivationMode Normal
LastCallFailure Last call failure
LastCallFailureCause Subscriber not contactable
LastCallFailureTimestamp 7/1/15 10:45:09 AM
LastCallFailureLogCorrelator 0429 01d8 5fd4 1c9b