Hi
i have a client that the PBX is only excepting 11 Digits caller ID for Example 1-718-555-1212 but if i will send 718-555-1212 it will not except the callerID, the problem is the carrier is sending the CallerID in 10 digits
how do i prefix the "1" to the callerID if its 10 digits
also the system is not sending out any callerID inforamtion for outgoing calls what will be my best option to set the callerID on the adtran
below is my configs file
!
!
hostname "TA904"
enable password encrypted 1e1695d7e1d5fdc85b1ea2fd1e9f4e2f1550
!
!
!
ip subnet-zero
ip classless
ip default-gateway 75.99.xxx.xxxx
ip routing
!
!
name-server 8.8.8.8
!
!
no auto-config
auto-config authname adtran encrypted password 2f2937fe188160c17f6c2215dd4664bfcfd8
!
event-history on
event-history size 256
no logging forwarding
no logging email
!
service password-encryption
!
username "moshe" password encrypted "272f935baee2ee2e470a839aa58a7da49d2f"
!
!
ip firewall
ip firewall stealth
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
description WAN
ip address 75.99.xxx.xxxx 255.255.255.xxx
ip mtu 1500
ip access-policy Public
no shutdown
media-gateway ip primary
!
!
!
!
interface t1 0/1
no shutdown
!
interface t1 0/2
description PBX PRI
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description PRI PBX Handoff
isdn name-delivery setup
connect t1 0/2 tdm-group 1
digits-transferred 4
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
!
!
ip access-list extended Admin
remark Admin Access
permit tcp any any eq ssh log
permit tcp any any eq https log
!
ip access-list extended SIP
remark SIP Service Provider
permit udp host xxx.202.xx.90 any eq 5060
!
ip access-list extended T
!
!
!
ip policy-class Public
allow list Admin self
allow list SIP self
allow list Admin self
allow list SIP self
!
!
no tftp server
no tftp server overwrite
http server
http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
sip
sip udp 5060
sip tcp 5060
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice trunk T01 type sip
description "denovo SIP"
sip-server primary sip.xxxxxxx.xxx
domain " sip.xxxxxxx.xxx"
dial-string source to
!
voice trunk T02 type isdn
description "PRI"
resource-selection linear ascending
connect isdn-group 1
t38
rtp delay-mode adaptive
!
!
voice grouped-trunk META
description "Meta Rules"
trunk T01
accept $ cost 0
!
!
voice grouped-trunk PBX
description "PBX Rules"
trunk T02
accept $ cost 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login local-userlist
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
!
!
!
end
TA904#
Two modifications, both on the PRI trunk:
To fix the inbound caller ID to your PBX users:
voice trunk T02 type isdn
description "PRI"
resource-selection linear ascending
connect isdn-group 1
t38
rtp delay-mode adaptive
match ani NXX-NXX-XXXX substitute 1-NXX-NXX-XXXX
To set the outbound caller ID from your PBX users:
voice trunk T02 type isdn
description "PRI"
resource-selection linear ascending
connect isdn-group 1
t38
rtp delay-mode adaptive
caller-id-override number-inbound 13125552368
caller-id-override name-inbound "Alex G Bell"
The second one is kind of counter-intuitive. "Inbound" and "outbound" are from the perspective of the TA900, so inbound from the PBX trunk is where you want to do the override. The caller-id that you set will propagate outbound to the SIP service provider. In many cases the PBX can be programmed to send caller-id, which can be useful if there are multiple DIDs and the customer wants them individually displayed. If you only want the TA900 to provide caller-id if it's missing from the PBX, you can modify the command like this:
caller-id-override number-inbound 13125552368 if-no-cpn
This will send the caller-id as received from the PBX if present. If the PBX fails to send it, the string programmed will be sent.
You also may want to, on your SIP trunk outbound, add the following:
voice trunk T01 type sip
description "denovo SIP"
sip-server primary sip.xxxxxxx.xxx
domain " sip.xxxxxxx.xxx"
dial-string source to
caller-id-override emergency-outbound 13125552368
This will send the configured number when the customer dials 9-1-1 regardless of what number if any is sent from the PBX.
Two modifications, both on the PRI trunk:
To fix the inbound caller ID to your PBX users:
voice trunk T02 type isdn
description "PRI"
resource-selection linear ascending
connect isdn-group 1
t38
rtp delay-mode adaptive
match ani NXX-NXX-XXXX substitute 1-NXX-NXX-XXXX
To set the outbound caller ID from your PBX users:
voice trunk T02 type isdn
description "PRI"
resource-selection linear ascending
connect isdn-group 1
t38
rtp delay-mode adaptive
caller-id-override number-inbound 13125552368
caller-id-override name-inbound "Alex G Bell"
The second one is kind of counter-intuitive. "Inbound" and "outbound" are from the perspective of the TA900, so inbound from the PBX trunk is where you want to do the override. The caller-id that you set will propagate outbound to the SIP service provider. In many cases the PBX can be programmed to send caller-id, which can be useful if there are multiple DIDs and the customer wants them individually displayed. If you only want the TA900 to provide caller-id if it's missing from the PBX, you can modify the command like this:
caller-id-override number-inbound 13125552368 if-no-cpn
This will send the caller-id as received from the PBX if present. If the PBX fails to send it, the string programmed will be sent.
You also may want to, on your SIP trunk outbound, add the following:
voice trunk T01 type sip
description "denovo SIP"
sip-server primary sip.xxxxxxx.xxx
domain " sip.xxxxxxx.xxx"
dial-string source to
caller-id-override emergency-outbound 13125552368
This will send the configured number when the customer dials 9-1-1 regardless of what number if any is sent from the PBX.
Thank you works great!
i was trying to add this rules to the SIP trunk and i didnt work but now that you point it out to do it on the PRI trunk it works great
FYI: CallerID name is not really working anymore in the USA the carriers are using thier own CNAM DB
mtghr wrote:
Thank you works great!
i was trying to add this rules to the SIP trunk and i didnt work but now that you point it out to do it on the PRI trunk it works great
FYI: CallerID name is not really working anymore in the USA the carriers are using thier own CNAM DB
Agreed that CNAM is the de-facto standard but it's common for other customers of your SIP carrier to get passthrough of what you send. If they peer with other SIP carriers it can be passed along as well. There's a small but real charge for CNAM dips, and if a name is present many carriers will avoid the dip charge. If it hits the SS7 network you'll get a CNAM dip.
The TA900 will also happily pass along name information from the PBX if it's there. This results in strange trouble tickets like, "When our receptionist calls company X (a different customer of your same SIP carrier), it shows our company name as 'Front Desk', what's happening?"