I am having an issue with a Mitel 200 el connecting to a Adtran 908e using a T1 for voice. I can get inbound dialing to work every time but outbound doesn't seem to be working at all. I am getting this error in my syslog "SMDR: 188 02/01/2016 04:01:44 0.0 0 I 00/01 00/00 T01 141925009900770 0 N" when we were just dialing '14192559070' from the phone system. Below is my config. Can anyone help out that would be great.
Building configuration...
!
!
! ADTRAN, Inc. OS version R10.9.6.E
! Boot ROM version R10.9.3.B2
! Platform: Total Access 908e (3rd Gen), part number 4243908F5
! Serial number XXXXXXXX
!
!
hostname "Customer"
enable password DELETED
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip default-gateway x.x.x.x
ip routing
ipv6 unicast-routing
!
!
!
!
no auto-config
!
event-history on
event-history priority notice
logging forwarding on
logging facility local0
logging forwarding priority-level debug
logging forwarding receiver-ip x.x.x.x
no logging email
!
no service password-encryption
!
username "user" password "DELTED"
!
banner motd #
Important
SSH & Web username/password is configured to admin/password.
Enable and Telnet passwords are configured to "password".
Please change them immediately.
The gig 0/1 interface is enabled with an address of 10.10.10.1
Telnet/SSH access is also enabled.
#
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
ip security monitor stats-filter web-stats-filter
threat 550
!
ip security monitor
stats-filter web-stats-filter
!
!
!
!
!
!
!
!
!
!
!
ip crypto ffe
!
!
!
!
!
!
!
interface eth 0/1
description WAN
ip address x.x.x.x x.x.x.x
ip mtu 1500
ip access-policy Public
media-gateway ip primary
no shutdown
!
!
interface eth 0/2
no ip address
shutdown
!
!
!
interface gigabit-eth 0/1
ip address 10.10.10.1 255.255.255.0
ip access-policy Private
no shutdown
!
!
!
!
interface t1 0/1
framing d4
coding ami
tdm-group 1 timeslots 1 speed 64
tdm-group 2 timeslots 2 speed 64
tdm-group 3 timeslots 3 speed 64
tdm-group 4 timeslots 4 speed 64
tdm-group 5 timeslots 5 speed 64
tdm-group 6 timeslots 6 speed 64
tdm-group 7 timeslots 7 speed 64
tdm-group 8 timeslots 8 speed 64
tdm-group 9 timeslots 9 speed 64
tdm-group 10 timeslots 10 speed 64
tdm-group 11 timeslots 11 speed 64
tdm-group 12 timeslots 12 speed 64
tdm-group 13 timeslots 13 speed 64
tdm-group 14 timeslots 14 speed 64
tdm-group 15 timeslots 15 speed 64
tdm-group 16 timeslots 16 speed 64
tdm-group 17 timeslots 17 speed 64
tdm-group 18 timeslots 18 speed 64
tdm-group 19 timeslots 19 speed 64
tdm-group 20 timeslots 20 speed 64
tdm-group 21 timeslots 21 speed 64
tdm-group 22 timeslots 22 speed 64
tdm-group 23 timeslots 23 speed 64
tdm-group 24 timeslots 24 speed 64
no shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
!
interface fxo 0/0
no shutdown
!
!
!
!
!
!
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended Inbound
permit ip host x.x.x.x any log
!
ip access-list extended self
remark Traffic to Total Access
permit ip any any log
!
ip access-list extended web-acl-5
permit tcp host x.x.x.x any eq www log
permit tcp host x.x.x.x any eq telnet log
permit udp host x.x.x.x any eq snmp log
permit tcp host x.x.x.x any eq https log
permit tcp host x.x.x.x any eq ssh log
permit tcp host x.x.x.x any eq ftp log
permit icmp host x.x.x.x any echo log
!
ip access-list extended web-acl-6
remark Colo
permit tcp host x.x.x.x any eq www log
permit tcp host x.x.x.x any eq telnet log
permit udp host x.x.x.x any eq snmp log
permit tcp host x.x.x.x any eq https log
permit tcp host x.x.x.x any eq ssh log
permit tcp host x.x.x.x any eq ftp log
permit icmp host x.x.x.x any echo log
!
ip access-list extended web-acl-7
remark EC1
permit ip host x.x.x.x any
!
ip access-list extended web-acl-8
remark EC2
permit ip host x.x.x.x any
!
!
!
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface eth 0/1 overload
!
ip policy-class Public
allow list web-acl-5 self
allow list web-acl-6 self
allow list web-acl-7
allow list web-acl-8
!
!
!
no tftp server
no tftp server overwrite
http server
http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-XXXX
!
!
!
!
!
voice trunk-list PRI
trunk T03
!
voice trunk-list SIP
trunk T01
!
!
voice trunk T01 type sip
description "SIPTrunk1"
sip-server primary x.x.x.x
sip-server secondary x.x.x.x
max-number-calls 24
!
voice trunk T03 type t1-rbs supervision wink role network
description "T1"
did digits-transferred 4
connect t1 0/1 tdm-group 1
connect t1 0/1 tdm-group 2
connect t1 0/1 tdm-group 3
connect t1 0/1 tdm-group 4
connect t1 0/1 tdm-group 5
connect t1 0/1 tdm-group 6
connect t1 0/1 tdm-group 7
connect t1 0/1 tdm-group 8
connect t1 0/1 tdm-group 9
connect t1 0/1 tdm-group 10
connect t1 0/1 tdm-group 11
connect t1 0/1 tdm-group 12
connect t1 0/1 tdm-group 13
connect t1 0/1 tdm-group 14
connect t1 0/1 tdm-group 15
connect t1 0/1 tdm-group 16
connect t1 0/1 tdm-group 17
connect t1 0/1 tdm-group 18
connect t1 0/1 tdm-group 19
connect t1 0/1 tdm-group 20
connect t1 0/1 tdm-group 21
connect t1 0/1 tdm-group 22
connect t1 0/1 tdm-group 23
connect t1 0/1 tdm-group 24
rtp delay-mode adaptive
!
!
voice grouped-trunk CustomerSIPTrunk
trunk T01
accept $ cost 0
permit list PRI
!deny all other trunks
!deny all other ani
!
!
voice grouped-trunk CustomerT1
trunk T03
accept $ cost 0
permit list SIP
!deny all other trunks
!deny all other ani
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip rtp symmetric-filter
!
!
ip rtp quality-monitoring
!
line con 0
login
!
line telnet 0 4
login
password DELETED
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
sntp server 10.20.10.5
!
!
!
!
another problem is that by default, there is no outbound caller ID on RBS trunks.
Try adding this command to your T03, copy and paste these commands after you change the XXX-XXX-XXXX to be your customer's main BTN (Billing telephone number) or what ever they want their caller ID to be.
voice trunk T03
caller-id-override number-inbound XXX-XXX-XXXX
that will probably fix your problem. What that command does is when calls come into the AOS switchboard, we apply that number as the ANI or caller ID number. Without that, the From field in the SIP Header has no number and most softswitches will reject it..
-Mark
Jonathan, please reply with the output of the following 3 debugs running together when attempting an outbound call:
debug voice verbose
debug sip stack message
debug isdn l2-format
Thanks
Jay
other thing to is that your only set up for 7 digit local dialing for the auto-complete template
You need to add long distance plans also like this:
voice dial-plan 2 long-distance 1-NXX-NXX-XXXX
once you provide the debugs that Jay requested, then we can find out where the problem is.
-Mark
another problem is that by default, there is no outbound caller ID on RBS trunks.
Try adding this command to your T03, copy and paste these commands after you change the XXX-XXX-XXXX to be your customer's main BTN (Billing telephone number) or what ever they want their caller ID to be.
voice trunk T03
caller-id-override number-inbound XXX-XXX-XXXX
that will probably fix your problem. What that command does is when calls come into the AOS switchboard, we apply that number as the ANI or caller ID number. Without that, the From field in the SIP Header has no number and most softswitches will reject it..
-Mark
Hi guys,
Not sure why the syslog was showing a malformed CID when dialing out but I found after running these commands that my carrier was give a 503 error. I have fixed this with the carrier. Thank you guys for your help. Without these commands I wouldn't have figure it out.
thanks for the update and glad you got it resolved!
-Mark