hi
i have an adtran 904e
i have a sip trunk connected to the WAN port
and PBX system to the T1 0/4 port
and FSX lines
i set up an FSX port and incoming calls works fine outgoing is routing to the the local PRI port to the local PBX and not to the SIP trunk
below is my config file
!
!
! ADTRAN, Inc. OS version R13.2.0.E
! Boot ROM version 14.05.00.SA
! Platform: Total Access 908e (2nd Gen), part number 4242908L1
! Serial number CFG0957834
!
!
hostname "TA908e"
enable password xxxxxxxxxxxx
!
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip default-gateway 47.23.xx.xxx
ip routing
ipv6 unicast-routing
!
!
name-server 8.8.8.8 192.168.2.249
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "abc" password "xxxxxxxxxxxxxxxxxx"
username "abc" password "xxxxxxxxxxxxxxxxxxxxxxx"
!
!
ip firewall
ip firewall stealth
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 192.168.2.60 255.255.255.0
no awcp
no shutdown
media-gateway ip primary
!
!
interface eth 0/2
description WAN
ip address 47.23.xx.xxx 255.255.255.248
ip mtu 1500
no awcp
no shutdown
media-gateway ip primary
!
!
!
!
interface t1 0/1
description PRI to PBX 2
tdm-group 2 timeslots 1-24 speed 64
no shutdown
!
interface t1 0/2
no shutdown
!
interface t1 0/3
no shutdown
!
interface t1 0/4
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description pri 1
isdn name-delivery setup
connect t1 0/4 tdm-group 1
digits-transferred 4
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
!
interface fxo 0/0
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
!
!
!
ip access-list extended Admin
remark Admin Access
permit tcp any any eq ssh log
permit tcp any any eq https
!
ip access-list extended SIP
remark SIP Service Provider
permit udp host 107.xx.xx.xxx any eq 5060
permit udp host 165.xx.xx.xxx any eq 5060
!
ip access-list extended T
!
!
!
!
ip policy-class Public
allow list Admin self
allow list SIP self
!
!
!
no tftp server
no tftp server overwrite
http server
http secure-server 445
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-XXX-XXXX
voice dial-plan 2 long-distance 1-NXX-XXX-XXXX
voice dial-plan 3 toll-free MXXX
!
!
!
!
!
!
voice trunk T01 type sip
match dnis "NXX-NXX-XXXX" substitute "1NXX-NXX-XXXX" name "Add 1 to local number"
sip-server primary sip.xxxxxx.cloud
domain "sip.xxxxxx.cloud"
dial-string source to
grammar from user international
!
voice trunk T02 type isdn
resource-selection circular descending
connect isdn-group 1
no early-cut-through
t38
rtp delay-mode adaptive
!
!
voice grouped-trunk PRI
trunk T02
accept $ cost 0
!
!
voice grouped-trunk SIP
trunk T01
accept $ cost 0
!
!
voice user 00001
connect fxs 0/1
no cos
password "1234"
did "716705xxxx"
sip-identity 00001 T01 register auth-name "00001" password "1234"
!
!
!
voice user 00002
connect fxs 0/2
no cos
password "1234"
!
!
!
voice user 00003
connect fxs 0/3
no cos
password "1234"
!
!
!
voice user 00004
connect fxs 0/4
no cos
password "1234"
!
!
!
voice user 00005
connect fxs 0/5
no cos
password "1234"
!
!
!
voice user 00006
connect fxs 0/6
no cos
password "1234"
!
!
!
voice user 00007
connect fxs 0/7
no cos
password "1234"
!
!
!
voice user 00008
connect fxs 0/8
no cos
password "1234"
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
!
!
!
end
TA908e#
Message was edited by: Patrick Crawford
edited the DID phone number under the "voice user" to make it more anonymous.
On the voice grouped-trunk facing the PBX, limit the accept pattern to just those DIDs that the PBX should be accepting. For example, if your PBX accepts 311-555-2300 through 311-555-2399 make it something like:
voice grouped-trunk PRI
trunk T02
accept 31155523XX cost 0
You may have to tweak it slightly if your carrier is sending other than ten digits (add a leading 1, don't include the area code, etc.)
On the voice grouped-trunk facing the PBX, limit the accept pattern to just those DIDs that the PBX should be accepting. For example, if your PBX accepts 311-555-2300 through 311-555-2399 make it something like:
voice grouped-trunk PRI
trunk T02
accept 31155523XX cost 0
You may have to tweak it slightly if your carrier is sending other than ten digits (add a leading 1, don't include the area code, etc.)
What @jayh said will work. Our situation is slightly different in that we aren't using FXS ports, and we have a long and frequently changing list of DIDs. But it was still trying to route back to the PRI instead of SIP. What we ended up doing was something like this:
voice trunk-list PRI
trunk T02
voice trunk-list SIP
trunk T01
And then under the grouped trunks:
voice grouped-trunk PRI
trunk T02
accept $ cost 0
permit list SIP
voice grouped-trunk SIP
trunk T01
accept $ cost 0
permit list PRI
This allows us to not have to maintain the list of DIDs within the config. It also has the benefit of protecting us from looping calls between SIP trunks, once we added more than one.
I do not know if you could add an FXS port to a "permit list" (voice trunk-list) or if the way that @jayh described is the only way it can work with FXS.
jayh
will that work for me with the permit SIP
this will make it easier for me then managing the DID list
mtghr wrote:
will that work for me with the permit SIP
this will make it easier for me then managing the DID list
Is managing the DID list a burden? How often do you change DIDs on your PBX? It's typically a set-and-forget type of thing, and they're usually in blocks. You can use REGEX-like syntax to enter chunks of sequential numbers in one or two lines. If you have a block of 100 DIDs you can enter it in one line. For sanity and to prevent weird behavior, it really makes sense in most cases not to send calls to the PBX that it isn't going to accept.
If you use SABR to force the FXS-originated calls out the SIP trunk, then you won't be able to dial the PBX directly from the FXS. Calls might go through but if they do they'll hairpin out the SIP provider.
You might be able to get away with something like leaving the PRI with an accept-all wildcard but increase the cost. This will ensure that the FXS calls will prefer the SIP trunk, but if the SIP trunk rejects them they'll land on the PRI. This will also hairpin FXS calls to the PBX through the SIP provider. Something like:
voice grouped-trunk PRI
trunk T02
accept $ cost 100
If you indeed have an odd situation where the DIDs landing on the PBX change very frequently, this might be your best solution.