We are trying to configure a 908e as a basic router. We uploaded the factory default config file for 908e models from Adtran.
We have eth 0/1 plugged into a layer 2 netgear layer 2 POE switch. We have eth 0/2 plugged into a 4G LTE router in IP passthrough mode.
We want the Adtran to hand out private DHCP addresses to phones connected to the POE switch which is connected to eth 0/1. We want to use the internal 192.168.1.X range.
The 4G LTE router hands the static public IP to any device connected to its lan port. So we have the eth 0/2 connected to the lan port on the 4G LTE router.
We try to put eth 0/2 into address type: DHCP , but get error
Unable to insert row for DHCP.
This is through the Adtran web GUI. We don't do command line.
How does the Adtran determine which ethernet port to spit out DHCP addresses to, and which ethernet port to get IPs for other DCHP assigning routers (In the case the 4G LTE router)?
Then I assume the adtran has to perform NAT between these two ports.
If anyone can post a sample config or let us know what we are doing wrong that would be great.
fiberman wrote:
We are trying to configure a 908e as a basic router. We uploaded the factory default config file for 908e models from Adtran.
We have eth 0/1 plugged into a layer 2 netgear layer 2 POE switch. We have eth 0/2 plugged into a 4G LTE router in IP passthrough mode.
We want the Adtran to hand out private DHCP addresses to phones connected to the POE switch which is connected to eth 0/1. We want to use the internal 192.168.1.X range.
In GUI, System tab- then Physical Interfaces.
Click on Eth 0/1 in the list.
Click the Enable box, and drop-down IP Routing.
Under IP Settings choose Static
Enter the IP address for this LAN interface, typically 192.168.1.1 or 192.168.1.254 with a netmask of 255.255.255.0 .
Select Media-Gateway of Primary .
Apply.
The 4G LTE router hands the static public IP to any device connected to its lan port. So we have the eth 0/2 connected to the lan port on the 4G LTE router.
We try to put eth 0/2 into address type: DHCP , but get error
Unable to insert row for DHCP.
Now go back to System -> Physical Interfaces .
Click on Eth 0/2 in the list.
Click the Enable box, and drop-down IP Routing.
Under IP Settings choose DHCP.
Select Media-Gateway of Primary .
Apply.
We want the Adtran to hand out private DHCP addresses to phones connected to the POE switch which is connected to eth 0/1. We want to use the internal 192.168.1.X range.
Now go back to System -> DHCP Server
Add a new pool, name it "Phones-pool" or similar.
Under IP Addresses enter 192.168.1.0 with a netmask of 255.255.255.0 .
Enter the IP address that you assigned to eth 0/1 as the Default gateway (192.168.1.1 or 192.168.1.254).
Under Optional Configuration enter the Primary DNS and Secondary DNS assigned by your ISP as well as any other options to pass to the LAN subnet. Apply.
How does the Adtran determine which ethernet port to spit out DHCP addresses to, and which ethernet port to get IPs for other DCHP assigning routers (In the case the 4G LTE router)?
On the WAN it is a DHCP client obtaining its address from a DHCP server.
On the LAN it is a DHCP server providing addresses to the client devices. It does this by matching the IP addresses in the Pool to the IP address and netmask statically configured on its interface(s).
This is through the Adtran web GUI. We don't do command line.
If anyone can post a sample config or let us know what we are doing wrong that would be great.
I can but if you don't do command line it won't make much sense to you. You still need to set up NAT and the like.
I followed you exact instruction (this is how I normally do this exact setup), but I am still getting a
Unable to insert row for DHCP.
on Eth 0/2 when I follow your instructions?
Can you provide a configuration dump with passwords redacted? It sounds like there may be something obscure not showing in the GUI that's interfering with DHCP.
!
enable password password
!
ip subnet-zero
ip classless
ip domain-proxy
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
username "admin" password "password"
!
banner motd #
Important
Web username/password is configured to admin/password.
Enable and Telnet passwords are configured to "password".
Please change them immediately.
The ethernet 0/1 interface is enabled with an address of 10.10.10.1
Telnet/SSH access is also enabled.
#
!
!
no ip firewall alg h323
!
!
!
!
!
!
ip dhcp-server pool "Private"
network 10.10.10.0 255.255.255.0
netbios-node-type h-node
default-router 10.10.10.1
lease 1
!
!
!
interface eth 0/1
ip address 10.10.10.1 255.255.255.0
no shutdown
!
interface eth 0/2
shutdown
!
!
interface t1 0/1
no shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
!
!
!
ip telnet-server 23
ip ssh-server 22
no ip tftp server
ip http server
ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
voice feature-mode network
!
!
!
!
!
!
!
ip sip
!
line con 0
no login
!
line telnet 0 4
login
password password
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
end
Wow, that looks like a default out-of-the-box configuration. Try something like this:
!
ip dhcp-server pool "Private"
no network 10.10.10.0 255.255.255.0
network 192.168.1.0 255.255.255.0
netbios-node-type h-node
dns-server <list of IPs here for resolvers.>
default-router 192.168.1.1
lease 1
!
!
interface eth 0/1
description LAN to switch
ip address 192.168.1.1 255.255.255.0
ip access-policy Private
media-gateway ip primary
no shutdown
!
interface eth 0/2
description Internet via 4G LTE
ip address dhcp
ip access-policy Public
media-gateway ip primary
no shutdown
!
ip access-list extended self
remark Traffic to Total Access
permit ip any any
ip access-list standard ics
remark Internet Connection Sharing
permit any
ip policy-class Public
allow list self self
ip policy-class Private
allow list self self
nat source list ics interface eth 0/2 overload
Are you sure that your 4G device is indeed passing a public address and not a NAT address in the same range as you're using for the LAN? If you connect it to your laptop what IP do you get?
Well I uploaded the config you typed out, but now I am locked out as I didn't enable SSH or HTTP access as it wasn't in the config. I don't have a serial cable on me, so it looks like I am locked out for now.
Yes, when I plug in my laptop with DCHP enabled the 4G router hands me a public static IP address. I get that Unable to insert row for DHCP when assigning to eth 0/2 even when I haven't plugged the Adtran into the 4GLTE router yet.
I have done quite a few Adtran devices with DHCP, and never ran across this Unable to insert row for DHCP error. This unit is on the latest software release, so I am wondering if maybe there is a bug or something.
Oh! I assumed you were local and were just going to replace the config sections with what I sent you and not erase everything and start over.
Here's an HHH for the next time:
When enabled and not in config mode, type:
reload in 10
(answer yes to save config and reload questions)
conf t
(make your changes)
If you lock yourself out, just wait. Ten minutes after the "reload in 10" the box will reboot. Because you were locked out, you weren't able to save whatever you did to lock yourself out, so when the box reboots it will revert to the last saved configuration, which is what you just did when you answered yes to the save question.
If you don't lock yourself out, then after you've made your changes exit config mode and type "reload cancel" and carry on, then save your latest changes.
The "10" in "reload in 10" is the number of minutes it will wait before the unit reboots. This can be anything convenient. Some firewall changes will disconnect your session, so leave enough time to log back in.
Interesting I will have to use this next time. I can ping the router of course, but I assume there is no way in besides serial if I just used the config you provided right?
If you left the default and just added what I pasted try user admin password password . Or try telnet with password password . Otherwise you'll need to console in.
fiberman wrote:
Interesting I will have to use this next time. I can ping the router of course, but I assume there is no way in besides serial if I just used the config you provided right?
If you weren't able to save it (and didn't copy it to startup), just power-cycle the box.
Fiberman,
Were you able to get this resolved? As Jay mentioned above, if you lock yourself out while pasting in the configuration in a Telnet or SSH session, a reboot will restore the previously saved configuration. If you uploaded an incomplete configuration directly to the startup-config file and rebooted the unit, you may need console/serial port access to finish up the configuration.
Thanks,
David