We have a new 908e gen 3 we are testing for a potential new subscriber. The customer is wanting redundant ISP in case the primary link goes down. I think I have that part figured out. This will be served with a Sip trunk to the front of the 908e and a PRI out the back for the time being, with the provision they could upgrade the PBX to sip capabilities at a later date. No problem there either. The issue I am having is when we go into failover on the wan, and the secondary becomes active, I see 0 sip traffic via the debug sip stack messages to say that the Adtran is even trying to talk to the provider(me). We run a Metaswitch and Perimeta SBC. Guess I am curious if the Adtran will actively try to talk with the far end SBC even if it isnt provisioned correctly, as in a OPTIONS message and a get lost response, I attached a configuration for the Adtran.
Got this working, needed to get away from the "peering" side of our SBC, and move to the "general access" so we could have the sip trunk from the Adtran register. We have not done that before, all of our sip trunks we keep on the "peering" side and hard code the WAN IP's of the Adtrans in the our switch and SBC for security, along with credentials. With the trunk registering it seems to work fine on WAN fail over
I guess the next question also would be, can you do 2 sip trunks, one per interface, on the 908e, then when it failed over, the switch would see 1 configured binding down, and would route calls to the one that was up, IE the secondary? Sorry for rambling, thanks folks
Got this working, needed to get away from the "peering" side of our SBC, and move to the "general access" so we could have the sip trunk from the Adtran register. We have not done that before, all of our sip trunks we keep on the "peering" side and hard code the WAN IP's of the Adtrans in the our switch and SBC for security, along with credentials. With the trunk registering it seems to work fine on WAN fail over
Riker,
How do you manipulate the TA900 into re-registering when the first circuit fails over? or are you relying on the registration expiration?
(presuming that you are still using the TA900 to hand off an ePRI)
Riker424,
Did you figure out how to get 2 sip trunks, one per interface. I would like to know how to do this too.
@riker424, You said you got this to work. I am facing a similar problem. Could you please share how you configured the trunk on the MetaSwitch as a registered trunk instead of hard coding the Adtran IP.
Thanks.
So we run a Metaswitch and a Perimeter SBC, which is also Metaswitch made. In a basic configuration the Perimeter should have at least 2 outside facing adjacencies, 1 will be peering, and 1 will be registering. The Peering adjacency will not allow registers to come into it. The Registering adjacency is general what you would use for Hosted PBX, or sip clients/phones. Each adjacency will have a local ip address that the far end devices need to communicate with. This is basic, I know other folks setups could and will be more complicated. So with that being said to be able to get a "registering" sip trunk set up in the Metaswitch you will need to attach it to the registering adjancency. You can make the sip binding in the Metaswitch the same way as other ones, "Learned contact details" needs to be set to true, and the "SIP domain name" needs to match your registering adjancency local ip address. "Learned contact details"
|
So that is at least the Switch side
I will paste my example config, scrubbed. In our test we used STATIC interface and PPPOE for another interface on the wan side of the Adtran.
ip local policy route-map LOCAL
probe WAN1 icmp-echo
destination X.X.X.1
source-address X.X.X.19
period 3
tolerance consecutive fail 5 pass 40
no shutdown
!
track WAN1
test if probe WAN1
no shutdown
interface eth 0/1
description XXXXXXXXXXXXX
ip address X.X.X.19 X.X.X.X
ip access-policy InterNet-Public_1
media-gateway ip primary
no shutdown
no lldp send-and-receive
!
!
interface eth 0/2
description UPLINK PPPOE
no ip address
no shutdown
no lldp send-and-receive
interface t1 0/3
tdm-group 1 timeslots 1-24 speed 64
no shutdown
interface pri 1
isdn switch-type 5ess
connect t1 0/3 tdm-group 1
no shutdown
interface ppp 1
ip address negotiated 10
ip mtu 1452
ip access-policy InterNet-Public_2
media-gateway ip primary
no fair-queue
ppp chap hostname XXXX@XXXX
ppp chap password encrypted 464e700e59f5b6ae542c3e3b8fe320bf9b29
no shutdown
cross-connect 1 eth 0/2 ppp 1
!
!
isdn-group 1
connect pri 1
route-map LOCAL permit 10
match ip address WAN1
set ip next-hop X.X.X.1
set interface eth 0/1 null 0
ip access-list standard NAT_PRI
remark Internet Connection Sharing
permit any
!
ip access-list standard NAT_SEC
remark Internet Connection Sharing
permit any
!
ip access-list extended WAN1
permit icmp host X.X.X.19 host X.X.X.1
!
no ip policy-class InterNet-Public_1 rpf-check
ip policy-class InterNet-Public_1
allow reverse list InterVLAN stateless
allow list SIP self
allow list management self
allow list WAN1 self
!
ip policy-class InterNet-Public_2
allow reverse list InterVLAN stateless
allow list SIP self
allow list management self
!
ip policy-class Private
allow list self self
allow list InterVLAN stateless
nat source list NAT_PRI interface eth 0/1 overload policy InterNet-Public_1
nat source list NAT_SEC interface ppp 1 overload policy InterNet-Public_2
!
!
!
ip route 0.0.0.0 0.0.0.0 X.X.X.1 track WAN1
voice trunk T01 type sip
description "METASWITCH"
sip-server primary X.X.X.X
dial-string source to
register XXXXXX auth-name "XXXXXXX" password encrypted "1e12dc02928fbe6f9d486740126e76c7347e"
trust-domain p-asserted-identity-required
authentication username "XXXXXXX" password encrypted "3a3667874c092537ddf01ec7f25f1b5a2cc9"
Ok some answers
Riker,
How do you manipulate the TA900 into re-registering when the first circuit fails over? or are you relying on the registration expiration?
(presuming that you are still using the TA900 to hand off an ePRI)
When there is a wan failover, the Adtran will try to immediately register again with the SBC, when it does, and you have the configured sip binding in the Metaswitch set to Learns contact details, it will capture the new registration, learn the IP address, and start forwarding calls to it. It will drop the old registration and not remember it. Secondly on wan failover you can set timers on how much time you want to wait until that primary internet services has been up before you switch back. That is in the WAN1 configuration
probe WAN1 icmp-echo
destination X.X.X.1
source-address X.X.X.19
period 3
tolerance consecutive fail 5 pass 40
no shutdown
Riker424,
Did you figure out how to get 2 sip trunks, one per interface. I would like to know how to do this too.
No, I dont think you can do it 2 per 1 interface. I thought I have read some articles where you could use 2 wan interfaces and have 2 sip trunks, that is 1 for 1.
@riker424, You said you got this to work. I am facing a similar problem. Could you please share how you configured the trunk on the MetaSwitch as a registered trunk instead of hard coding the Adtran IP.
I tried to describe it on the top section, hopefully that will get you going, if not give me another message and will try again. Good Luck Folks!