Hello everyone,
I'm new to the TDM world even though I've worked in the SIP world just for a few years.
The company I work for uses a lot of Adtran devices (900 series at customer premise)
We have an Adtran 908 at a customer premise. This device is connected to our network via IP via vpn (No NAT). I have access to both SSH and web gui.
It was previously configured and working but hasn't been used in 6 months or more. I can see that the device is set to peer to the sip server and shows ready. When I call a number that is directed to it, the adtran receives the call, but seems to redirect it back to our Sonus.
Suggestions? I'm unsure what information is needed as I'm so green to Adtran.
Your issue is with the SIP server initiating the call and not with the analog FXS station.
Generally, a call is initiated with a SIP INVITE message having the call details such as calling and called number, IP and port for the RTP session (SDP), and other data related to the call.
Your provider, however, first sends an OPTIONS message to determine if your device is alive and ready to accept a call. It's kind of like asking "Are you there?" before delivering a message. OPTIONS can also query such things as SDP capabilities and the like, but this doesn't seem to be the case here. If the sender gets a response that indicates the call will fail, or gets no response at all, then no INVITE is ever sent.
Looking at the debug, you receive the OPTIONS message and immediately respond with an OK stating your capabilities including that you can accept an INVITE.
Apparently, the SIP server at 192.192.192.99 never receives your reply. Therefore it never sends the INVITE. Seeing as the OPTIONS messages are received every 15 seconds exactly, my guess is that the sending server is not receiving your replies and is set to retry three times at 15-second intervals, then give up.
This could be an IP routing issue, a firewall rule somewhere, or simply broken behavior on the part SIP sender. Further examination of your configuration indicates something odd. You have:
!
ip route 0.0.0.0 0.0.0.0 10.0.250.1
ip route 0.0.0.0 0.0.0.0 71.41.86.201
ip route 0.0.0.0 0.0.0.0 96.252.180.1
!
Yet the only connected IP interface is eth 0/1 which is in the 10.0.250.0/24 space. Therefore your second two default routes should be removed.
However, 10.0.250.0/24 is a private address. You say there's a VPN between it and your network with no NAT. Is the SIP server "sonus" also on your network with no NAT, or does it traverse an external NAT to go to the Internet to reach "sonus"? You will want to avoid NAT between the Adtran TA900 and the SIP server.
At any rate, if the response to the OPTIONS message isn't received and processed, then the INVITE will also almost certainly fail.
Troubleshoot the path from your TA908 back to SIP server "sonus" and you'll probably find the issue.
astrosean wrote:
It was previously configured and working but hasn't been used in 6 months or more. I can see that the device is set to peer to the sip server and shows ready. When I call a number that is directed to it, the adtran receives the call, but seems to redirect it back to our Sonus.
Where is the call supposed to go? Is there a PRI connected to it? A SIP PBX? Individual analog users? It could be that the call is reaching the customer PBX and that is hairpinning the call back. Can the customer place outbound calls OK?
A sanitized configuration (remove passwords and public IP info) and the results of "debug voice verbose" when a call is placed would be useful.
Here you go..
Call is supposed to go to a FXS port (analog user).
Unsure about outbound calls. I have a call into the on premise to test outbound calls. Awaiting response from them.
Here is a sanitized copy of the config.
The number of concern is 7273025555
!
!
!
hostname "helpme"
enable password boom12345
!
clock timezone -5-Eastern-Time
!
statistics rate-interval 30
!
ip subnet-zero
ip classless
ip default-gateway 10.0.250.1
ip routing
!
!
ip domain-name "sometelecom.net"
ip name-server 8.8.8.8 4.2.2.3
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password "adminpass123abc"
username "mike" password "boom12345"
username "adtran" password "flylikeabird"
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
ip dhcp-server pool "Test"
!
!
!
!
!
!
qos map ConfigWizardQoSMap 20
match dscp 46
priority unlimited
!
!
!
!
interface eth 0/1
description HelpMe
ip address 10.0.250.2 255.255.255.0
media-gateway ip primary
no shutdown
!
!
!
!
interface t1 0/1
description PRI Port
shutdown
!
interface t1 0/2
description helpme
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description helpme
isdn name-delivery setup
connect t1 0/2 tdm-group 1
role network b-channel-restarts enable
no shutdown
!
!
interface fxs 0/1
description "7273024444"
no shutdown
!
interface fxs 0/2
description "7273025555"
no shutdown
!
interface fxs 0/3
shutdown
!
interface fxs 0/4
shutdown
!
interface fxs 0/5
impedance 600r
shutdown
!
interface fxs 0/6
impedance 600r
shutdown
!
interface fxs 0/7
impedance 600r
shutdown
!
interface fxs 0/8
impedance 600r
shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
timing-source internal
!
timing-source internal secondary
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 10.0.250.1
ip route 0.0.0.0 0.0.0.0 71.41.86.201
ip route 0.0.0.0 0.0.0.0 96.252.180.1
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http session-timeout 1200
ip http session-limit 10
ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
ip sntp server
!
!
!
!
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
voice call-appearance-mode single
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-NXX-XXXX
voice dial-plan 3 long-distance 1-NXX-NXX-XXXX
voice dial-plan 4 toll-free 1-800-NXX-XXXX
voice dial-plan 5 toll-free 1-877-NXX-XXXX
voice dial-plan 6 toll-free 1-866-NXX-XXXX
voice dial-plan 7 toll-free 1-855-NXX-XXXX
voice dial-plan 8 always-permitted 511
voice dial-plan 9 always-permitted 411
voice dial-plan 10 always-permitted 1-411
voice dial-plan 11 always-permitted 555-1212
voice dial-plan 12 international 011-XXXXXXXXXX
voice dial-plan 13 international 011-XXXXXXXXXXX
voice dial-plan 14 international 011-XXXXXXXXXXXX
voice dial-plan 15 international 011-XXXXXXXXXXXXX
voice dial-plan 16 international 011-XXXXXXXXXXXXXX
voice dial-plan 17 international 011-XXXXXXXXXXXXXXX
voice dial-plan 18 international 011-XXXXXXXXXXXXXXXX
voice dial-plan 19 local 611
!
!
!
!
voice class-of-service flylikeabirdTrk
default-level
billing-codes
call-privilege extensions
call-privilege international
call-privilege local
call-privilege long-distance
call-privilege operator-assisted
call-privilege specify-carrier
call-privilege toll-free
call-privilege 900-number
!
voice codec-list whirlpool
default
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "sonus"
sip-server primary 192.192.192.99
!
voice trunk T02 type isdn
description "ISDN"
resource-selection linear descending
caller-id-override number-inbound 7275737663 if-no-cpn
connect isdn-group 1
alc
modem-passthrough
t38
plc
rtp delay-mode adaptive
!
!
voice grouped-trunk "SIP TRUNK"
trunk T01
accept $ cost 0
accept NXX-NXX-XXXX cost 0
accept 1-NXX-NXX-XXXX cost 0
accept 1-800-NXX-XXXX cost 0
accept 1-888-NXX-XXXX cost 0
accept 1-877-NXX-XXXX cost 0
accept 1-866-NXX-XXXX cost 0
accept 1-855-NXX-XXXX cost 0
accept 911 cost 0
reject NXX-976-XXXX
reject 1-900-NXX-XXXX
reject 1-976-NXX-XXXX
!
!
voice grouped-trunk "ISDN TRUNK"
trunk T02
accept $ cost 10
!
!
voice user 7273024444
connect fxs 0/1
cos "flylikeabirdTrk"
first-name "Alarm"
last-name "Line"
password "1234"
description "7273024444"
sip-identity 7273024444 T01
sip-authentication password "1234"
no nls
no echo-cancellation
codec-group whirlpool
!
!
voice user 7273025555
connect fxs 0/2
cos "flylikeabirdTrk"
first-name "conference"
last-name "room"
password "1234"
sip-identity 7273025555 T01
sip-authentication password "1234"
no echo-cancellation
codec-group whirlpool
!
!
!
!
!
!
!
!
!
!
no ip sip registrar authenticate
ip sip registrar default-expires 5000
ip sip registrar min-expires 3600
ip sip registrar max-expires 5000
!
!
!
!
!
!
!
!
!
!
!
ip rtp udp 16384
!
ip sdp grammar hold rfc3264
!
!
line con 0
login
!
line telnet 0 4
login
password boom12345
shutdown
line ssh 0 4
login local-userlist
no shutdown
!
sntp server 216.182.242.7 version 3
sntp wait-time 500
!
!
!
!
end
Tried capturing voice verbose, but nothing happened during the failed call. However here are the results of SIP all.
12:16:12.467 SIP. MSG OPTIONS REQ RX unknown unknown
OPTIONS sip:10.0.250.2:5060 SIP/2.0
From: <sip:192.192.192.99>;tag=gK004cb43d
To: <sip:10.0.250.2>
Call-ID: 137742052_100523466@192.192.192.99
CSeq: 700098 OPTIONS
Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B163be93d364f02d4
Max-Forwards: 1
Contact: <sip:192.192.192.99:5060>
Content-Length: 0
12:16:12.468 SIP. MSGSUM OPTIONS REQ RX unknown unknown sip:10.0.250.2:5060
12:16:12.469 SIP.TDU Transaction accepted by SIP Server
12:16:12.470 SIP.TDU Incoming message received from 192.192.192.99:5060 via UDP
12:16:12.472 SIP. MSG OPTIONS RSP TX unknown unknown
SIP/2.0 200 OK
From: <sip:192.192.192.99>;tag=gK004cb43d
To: <sip:10.0.250.2>;tag=24c7c28-7f000001-13c4-1915-fb46dcb6-1915
Call-ID: 137742052_100523466@192.192.192.99
CSeq: 700098 OPTIONS
Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B163be93d364f02d4
Supported: 100rel,replaces
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
Content-Length: 0
12:16:12.473 SIP. MSGSUM OPTIONS RSP TX unknown unknown 200 OK
If nothing happened during the debug voice verbose, it sounds like the call either never hit the TA900 or the TA900 isn't accepting its SIP.
The SIP capture is an options message and doesn't look like it is necessarily related to your call.
Does "debug sip stack messages" show an INVITE message?
Also, while not related to this specific problem, your dial plan could use some tweaks. To avoid potential issues, you probably want to change the following to "local" instead of "always-permitted".
voice dial-plan 8 always-permitted 511
voice dial-plan 9 always-permitted 411
voice dial-plan 10 always-permitted 1-411
voice dial-plan 11 always-permitted 555-1212
always-permitted is for emergency calls.
And you should have:
voice dial-plan 2 always-permitted 911
In addition, 1-844-NXX-XXXX and 1-833-NXX-XXXX are now valid toll-free patterns.
Nice catch on those btw. Thank you!
Here's the latest debug capture
14:46:13.266 SIP.STACK MSG Rx: UDP src=192.192.192.99:5060 dst=10.0.250.2:5060
14:46:13.267 SIP.STACK MSG OPTIONS sip:10.0.250.2:5060 SIP/2.0
14:46:13.267 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1be13cc96d3ec07d
14:46:13.268 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003e22df
14:46:13.268 SIP.STACK MSG To: <sip:10.0.250.2>
14:46:13.269 SIP.STACK MSG Call-ID: 137793055_129880511@192.192.192.99
14:46:13.269 SIP.STACK MSG CSeq: 62701 OPTIONS
14:46:13.270 SIP.STACK MSG Max-Forwards: 1
14:46:13.270 SIP.STACK MSG Contact: <sip:192.192.192.99:5060>
14:46:13.271 SIP.STACK MSG Content-Length: 0
14:46:13.272 SIP.STACK MSG
14:46:13.282 SIP.STACK MSG Tx: UDP src=10.0.250.2:5060 dst=192.192.192.99:5060
14:46:13.283 SIP.STACK MSG SIP/2.0 200 OK
14:46:13.283 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003e22df
14:46:13.284 SIP.STACK MSG To: <sip:10.0.250.2>;tag=24b7008-7f000001-13c4-3c3e-feb52672-3c3e
14:46:13.285 SIP.STACK MSG Call-ID: 137793055_129880511@192.192.192.99
14:46:13.285 SIP.STACK MSG CSeq: 62701 OPTIONS
14:46:13.286 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1be13cc96d3ec07d
14:46:13.286 SIP.STACK MSG Supported: 100rel,replaces
14:46:13.287 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
14:46:13.287 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
14:46:13.288 SIP.STACK MSG Content-Length: 0
14:46:13.288 SIP.STACK MSG
14:46:28.266 SIP.STACK MSG Rx: UDP src=192.192.192.99:5060 dst=10.0.250.2:5060
14:46:28.266 SIP.STACK MSG OPTIONS sip:10.0.250.2:5060 SIP/2.0
14:46:28.267 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1c5dc0d28390b748
14:46:28.267 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003e93d4
14:46:28.268 SIP.STACK MSG To: <sip:10.0.250.2>
14:46:28.268 SIP.STACK MSG Call-ID: 137793140_133644708@192.192.192.99
14:46:28.269 SIP.STACK MSG CSeq: 612431 OPTIONS
14:46:28.269 SIP.STACK MSG Max-Forwards: 1
14:46:28.270 SIP.STACK MSG Contact: <sip:192.192.192.99:5060>
14:46:28.270 SIP.STACK MSG Content-Length: 0
14:46:28.271 SIP.STACK MSG
14:46:28.281 SIP.STACK MSG Tx: UDP src=10.0.250.2:5060 dst=192.192.192.99:5060
14:46:28.282 SIP.STACK MSG SIP/2.0 200 OK
14:46:28.282 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003e93d4
14:46:28.283 SIP.STACK MSG To: <sip:10.0.250.2>;tag=24b71c0-7f000001-13c4-3c4d-a21f0c2d-3c4d
14:46:28.283 SIP.STACK MSG Call-ID: 137793140_133644708@192.192.192.99
14:46:28.284 SIP.STACK MSG CSeq: 612431 OPTIONS
14:46:28.284 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1c5dc0d28390b748
14:46:28.285 SIP.STACK MSG Supported: 100rel,replaces
14:46:28.285 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
14:46:28.286 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
14:46:28.286 SIP.STACK MSG Content-Length: 0
14:46:28.287 SIP.STACK MSG
14:46:43.266 SIP.STACK MSG Rx: UDP src=192.192.192.99:5060 dst=10.0.250.2:5060
14:46:43.266 SIP.STACK MSG OPTIONS sip:10.0.250.2:5060 SIP/2.0
14:46:43.267 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1cdce041137e0640
14:46:43.267 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003f0b30
14:46:43.268 SIP.STACK MSG To: <sip:10.0.250.2>
14:46:43.268 SIP.STACK MSG Call-ID: 137793225_125491704@192.192.192.99
14:46:43.269 SIP.STACK MSG CSeq: 336093 OPTIONS
14:46:43.270 SIP.STACK MSG Max-Forwards: 1
14:46:43.270 SIP.STACK MSG Contact: <sip:192.192.192.99:5060>
14:46:43.271 SIP.STACK MSG Content-Length: 0
14:46:43.271 SIP.STACK MSG
14:46:43.282 SIP.STACK MSG Tx: UDP src=10.0.250.2:5060 dst=192.192.192.99:5060
14:46:43.282 SIP.STACK MSG SIP/2.0 200 OK
14:46:43.283 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003f0b30
14:46:43.283 SIP.STACK MSG To: <sip:10.0.250.2>;tag=24b7378-7f000001-13c4-3c5c-fa1b81a9-3c5c
14:46:43.284 SIP.STACK MSG Call-ID: 137793225_125491704@192.192.192.99
14:46:43.284 SIP.STACK MSG CSeq: 336093 OPTIONS
14:46:43.285 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1cdce041137e0640
14:46:43.285 SIP.STACK MSG Supported: 100rel,replaces
14:46:43.286 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
14:46:43.287 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
14:46:43.287 SIP.STACK MSG Content-Length: 0
14:46:43.288 SIP.STACK MSG
14:46:58.272 SIP.STACK MSG Rx: UDP src=192.192.192.99:5060 dst=10.0.250.2:5060
14:46:58.272 SIP.STACK MSG OPTIONS sip:10.0.250.2:5060 SIP/2.0
14:46:58.273 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1d51e6fd2a5d811d
14:46:58.274 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003f7657
14:46:58.274 SIP.STACK MSG To: <sip:10.0.250.2>
14:46:58.275 SIP.STACK MSG Call-ID: 137793310_133810858@192.192.192.99
14:46:58.275 SIP.STACK MSG CSeq: 222758 OPTIONS
14:46:58.276 SIP.STACK MSG Max-Forwards: 1
14:46:58.276 SIP.STACK MSG Contact: <sip:192.192.192.99:5060>
14:46:58.277 SIP.STACK MSG Content-Length: 0
14:46:58.277 SIP.STACK MSG
14:46:58.288 SIP.STACK MSG Tx: UDP src=10.0.250.2:5060 dst=192.192.192.99:5060
14:46:58.288 SIP.STACK MSG SIP/2.0 200 OK
14:46:58.289 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003f7657
14:46:58.289 SIP.STACK MSG To: <sip:10.0.250.2>;tag=24b7530-7f000001-13c4-3c6b-bcb55878-3c6b
14:46:58.290 SIP.STACK MSG Call-ID: 137793310_133810858@192.192.192.99
14:46:58.290 SIP.STACK MSG CSeq: 222758 OPTIONS
14:46:58.291 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1d51e6fd2a5d811d
14:46:58.292 SIP.STACK MSG Supported: 100rel,replaces
14:46:58.292 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
14:46:58.293 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
14:46:58.293 SIP.STACK MSG Content-Length: 0
14:46:58.294 SIP.STACK MSG
14:47:13.273 SIP.STACK MSG Rx: UDP src=192.192.192.99:5060 dst=10.0.250.2:5060
14:47:13.274 SIP.STACK MSG OPTIONS sip:10.0.250.2:5060 SIP/2.0
14:47:13.275 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1dc508aa00513a58
14:47:13.275 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003fe2e0
14:47:13.276 SIP.STACK MSG To: <sip:10.0.250.2>
14:47:13.276 SIP.STACK MSG Call-ID: 137793395_125572646@192.192.192.99
14:47:13.277 SIP.STACK MSG CSeq: 604056 OPTIONS
14:47:13.277 SIP.STACK MSG Max-Forwards: 1
14:47:13.278 SIP.STACK MSG Contact: <sip:192.192.192.99:5060>
14:47:13.278 SIP.STACK MSG Content-Length: 0
14:47:13.279 SIP.STACK MSG
14:47:13.289 SIP.STACK MSG Tx: UDP src=10.0.250.2:5060 dst=192.192.192.99:5060
14:47:13.290 SIP.STACK MSG SIP/2.0 200 OK
14:47:13.291 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK003fe2e0
14:47:13.291 SIP.STACK MSG To: <sip:10.0.250.2>;tag=24b76e8-7f000001-13c4-3c7a-a420a5d8-3c7a
14:47:13.292 SIP.STACK MSG Call-ID: 137793395_125572646@192.192.192.99
14:47:13.292 SIP.STACK MSG CSeq: 604056 OPTIONS
14:47:13.293 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1dc508aa00513a58
14:47:13.293 SIP.STACK MSG Supported: 100rel,replaces
14:47:13.294 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
14:47:13.294 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
14:47:13.295 SIP.STACK MSG Content-Length: 0
14:47:13.295 SIP.STACK MSG
14:47:28.274 SIP.STACK MSG Rx: UDP src=192.192.192.99:5060 dst=10.0.250.2:5060
14:47:28.275 SIP.STACK MSG OPTIONS sip:10.0.250.2:5060 SIP/2.0
14:47:28.275 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1e3da2bd8ab4b8bd
14:47:28.276 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK00404d1f
14:47:28.277 SIP.STACK MSG To: <sip:10.0.250.2>
14:47:28.277 SIP.STACK MSG Call-ID: 137793480_116376952@192.192.192.99
14:47:28.278 SIP.STACK MSG CSeq: 952914 OPTIONS
14:47:28.278 SIP.STACK MSG Max-Forwards: 1
14:47:28.279 SIP.STACK MSG Contact: <sip:192.192.192.99:5060>
14:47:28.279 SIP.STACK MSG Content-Length: 0
14:47:28.280 SIP.STACK MSG
14:47:28.290 SIP.STACK MSG Tx: UDP src=10.0.250.2:5060 dst=192.192.192.99:5060
14:47:28.291 SIP.STACK MSG SIP/2.0 200 OK
14:47:28.291 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK00404d1f
14:47:28.292 SIP.STACK MSG To: <sip:10.0.250.2>;tag=24b78a0-7f000001-13c4-3c89-eed3bfe3-3c89
14:47:28.292 SIP.STACK MSG Call-ID: 137793480_116376952@192.192.192.99
14:47:28.293 SIP.STACK MSG CSeq: 952914 OPTIONS
14:47:28.293 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1e3da2bd8ab4b8bd
14:47:28.294 SIP.STACK MSG Supported: 100rel,replaces
14:47:28.295 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
14:47:28.295 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
14:47:28.296 SIP.STACK MSG Content-Length: 0
14:47:28.296 SIP.STACK MSG
14:47:43.272 SIP.STACK MSG Rx: UDP src=192.192.192.99:5060 dst=10.0.250.2:5060
14:47:43.272 SIP.STACK MSG OPTIONS sip:10.0.250.2:5060 SIP/2.0
14:47:43.273 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1eaef3098d28c1c6
14:47:43.273 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK0040b8bb
14:47:43.274 SIP.STACK MSG To: <sip:10.0.250.2>
14:47:43.275 SIP.STACK MSG Call-ID: 137793565_129486139@192.192.192.99
14:47:43.275 SIP.STACK MSG CSeq: 790427 OPTIONS
14:47:43.276 SIP.STACK MSG Max-Forwards: 1
14:47:43.276 SIP.STACK MSG Contact: <sip:192.192.192.99:5060>
14:47:43.277 SIP.STACK MSG Content-Length: 0
14:47:43.277 SIP.STACK MSG
14:47:43.288 SIP.STACK MSG Tx: UDP src=10.0.250.2:5060 dst=192.192.192.99:5060
14:47:43.288 SIP.STACK MSG SIP/2.0 200 OK
14:47:43.289 SIP.STACK MSG From: <sip:192.192.192.99>;tag=gK0040b8bb
14:47:43.289 SIP.STACK MSG To: <sip:10.0.250.2>;tag=24b7a58-7f000001-13c4-3c98-d4678047-3c98
14:47:43.290 SIP.STACK MSG Call-ID: 137793565_129486139@192.192.192.99
14:47:43.290 SIP.STACK MSG CSeq: 790427 OPTIONS
14:47:43.291 SIP.STACK MSG Via: SIP/2.0/UDP 192.192.192.99:5060;branch=z9hG4bK00B1eaef3098d28c1c6
14:47:43.291 SIP.STACK MSG Supported: 100rel,replaces
14:47:43.292 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
14:47:43.292 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_908_1st_Gen/A4.11.00.E
14:47:43.293 SIP.STACK MSG Content-Length: 0
14:47:43.293 SIP.STACK MSG
Your issue is with the SIP server initiating the call and not with the analog FXS station.
Generally, a call is initiated with a SIP INVITE message having the call details such as calling and called number, IP and port for the RTP session (SDP), and other data related to the call.
Your provider, however, first sends an OPTIONS message to determine if your device is alive and ready to accept a call. It's kind of like asking "Are you there?" before delivering a message. OPTIONS can also query such things as SDP capabilities and the like, but this doesn't seem to be the case here. If the sender gets a response that indicates the call will fail, or gets no response at all, then no INVITE is ever sent.
Looking at the debug, you receive the OPTIONS message and immediately respond with an OK stating your capabilities including that you can accept an INVITE.
Apparently, the SIP server at 192.192.192.99 never receives your reply. Therefore it never sends the INVITE. Seeing as the OPTIONS messages are received every 15 seconds exactly, my guess is that the sending server is not receiving your replies and is set to retry three times at 15-second intervals, then give up.
This could be an IP routing issue, a firewall rule somewhere, or simply broken behavior on the part SIP sender. Further examination of your configuration indicates something odd. You have:
!
ip route 0.0.0.0 0.0.0.0 10.0.250.1
ip route 0.0.0.0 0.0.0.0 71.41.86.201
ip route 0.0.0.0 0.0.0.0 96.252.180.1
!
Yet the only connected IP interface is eth 0/1 which is in the 10.0.250.0/24 space. Therefore your second two default routes should be removed.
However, 10.0.250.0/24 is a private address. You say there's a VPN between it and your network with no NAT. Is the SIP server "sonus" also on your network with no NAT, or does it traverse an external NAT to go to the Internet to reach "sonus"? You will want to avoid NAT between the Adtran TA900 and the SIP server.
At any rate, if the response to the OPTIONS message isn't received and processed, then the INVITE will also almost certainly fail.
Troubleshoot the path from your TA908 back to SIP server "sonus" and you'll probably find the issue.
I've removed the additional default routes and I've verified two way connectivity between the 908 and the Sonus. Also, I've tripled checked the vpn config, and the routing is without NAT. (When we deploy a customer device, we reserve the IP space used in the private space within our network and just route the packets. We mainly did this before net neutrality was a thing, and now its even more important. )
BTW, is there a guide or a tree to lookup all the CLI commands for the 900 series and how they are used?
astrosean wrote:
I've removed the additional default routes and I've verified two way connectivity between the 908 and the Sonus. Also, I've tripled checked the vpn config, and the routing is without NAT. (When we deploy a customer device, we reserve the IP space used in the private space within our network and just route the packets. We mainly did this before net neutrality was a thing, and now its even more important. )
OK, next step would be to determine why the Sonus is unhappy with (or ignoring) the 200OK responses to the OPTIONS messages, or get it to not do the OPTIONS thing and just send an INVITE.
The problem seems to be that the Sonus doesn't see (or doesn't like) the response to its OPTIONS query and thus never sets up the call.
astrosean wrote:
BTW, is there a guide or a tree to lookup all the CLI commands for the 900 series and how they are used?
Oh, you must want "The Bible". 🙂 AOS Version R12.3 Command Reference Guide
Yep, already working withe Sonus engineer and explained to him that the invite doesn't seem to be sent.
For the Bible, have things changed much from v11 and v12? Looks like the latest this 908 supports is v11.
astrosean wrote:
Yep, already working withe Sonus engineer and explained to him that the invite doesn't seem to be sent.
For the Bible, have things changed much from v11 and v12? Looks like the latest this 908 supports is v11.
Most of the commands are the same. There are some new ones that are only in R12. A couple of years ago they tweaked the use of the "ip" keyword to differentiate between IPv4 and IPv6. Mostly, the "ip" was removed from commands that would apply equally to v4 and v6 and added where the specific version needed to be specified. This was mostly within the various flavors of R10.
When you upgrade, on the first reboot the configuration is parsed and tweaked as needed to be compatible with the new version. This works really well so no issues. However, if you ever need to roll back to an older version and the configuration was automatically modified, things will break. An archive utility like RANCID is your friend.
I also recommend that you archive any Adtran documentation and firmware that you use locally as they have become pretty aggressive about removing older versions from the website.
Understood thank you!
Well, still no luck on my side.
Is there any kind of step by step tutorial to configure one of these 900 series from scratch as an peering ATA (no registration)?. I feel as if I'm missing something and it'd do me some good to work with this as much as I can.
astrosean wrote:
Is there any kind of step by step tutorial to configure one of these 900 series from scratch as an peering ATA (no registration)?. I feel as if I'm missing something and it'd do me some good to work with this as much as I can.
Not per se that I'm aware of. Basic idea, set up a voice trunk type SIP with the other side as the SIP server (ip or hostname). Don't configure registration. Do the same on the other side with the ip of the TA900. You can do two of them back-to-back or set one up to peer with your SBC.
Then use the grouped-trunk to configure the digit patterns to send to the other side.
For more than one endpoint, build multiple trunks.
The GUI is easier initially to do much of this, but the CLI is more powerful. You can use the GUI to build a simple configuration and then use the CLI to see what was done and modify it. If you're going to be working with these devices a lot, learn to do everything in the CLI. Learning curve isn't that steep.
Just wanted to let you know we used a different sip server (our legacy one) and everything worked fine. Just updated the voip trunk to reflect the different ip, applied and rebooted and voila, magic. Go figure.
Thanks so much for helping a new guy.
Now that the fire is out, going to put one on a bench and set it up from scratch from the CLI.
I'd probably edit that post with the full config file unless those passwords were already preedited before you pasted / you don't care.