No audio as the call is being sent back to SBC. and SBC sees this coming from same IP (NAT'ed). Looking to see if there is a cmd i can enter (bridge)/ that allows phones to "Talk" across networks on same NetVanta.
ip dhcp pool "Data Network"
network 192.168.1.0 255.255.255.0
dns-server xxxxxxxx xxxxxxxxx
netbios-node-type h-node
default-router 192.168.1.1
option 42 ip 192.168.1.1
!
ip dhcp pool "Aastra Network"
vrf VoIP
network 10.10.10.0 255.255.255.0
dns-server xxxxxxxx xxxxxxxxxx
default-router 10.10.10.1
option 42 ip 10.10.10.1
!
ip dhcp pool "Polycom Network"
vrf VoIP
network 10.10.7.0 255.255.255.0
dns-server xxxxxxxxx xxxxxxxxx
default-router 10.10.7.1
option 42 ip 10.10.7.1
option 66 ascii https://xxxxxxxxxxxxx
vlan 1
name "Default"
!
vlan 6
name "Aastra_VoIP"
!
vlan 7
name "Polycom_VoIP"
!
vlan 21
name "WAN_Inet"
!
vlan 23
name "WAN_VoIP"
interface switchport 0/1
description Phone Port
spanning-tree edgeport
no shutdown
switchport mode trunk
switchport voice vlan 7 cos 3 dscp 24
switchport voice-signaling vlan 7 cos 3 dscp 24
!
interface switchport 0/2
description Phone Port
spanning-tree edgeport
no shutdown
switchport mode trunk
switchport voice vlan 6
switchport voice-signaling vlan 6 cos 3 dscp 24
no lldp send
interface vlan 1
description LAN Inet
ip address 192.168.1.1 255.255.255.0
no ip proxy-arp
ip access-policy NAT-Data
no awcp
no shutdown
!
interface vlan 6
description Aastra VoIP
vrf forwarding VoIP
ip address 10.10.10.1 255.255.255.0
no ip proxy-arp
ip access-policy NAT-VoIP
media-gateway ip primary
qos-policy in SET-DSCP-LAN
no awcp
no shutdown
!
interface vlan 7
description Polycom VoIP
vrf forwarding VoIP
ip address 10.10.7.1 255.255.255.0
no ip proxy-arp
ip access-policy NAT-VoIP
media-gateway ip primary
qos-policy in SET-DSCP-LAN
no awcp
no shutdown
Assuming that MATCH-PRIVATE-VoIP contains both 10.10.7.0/24 and 10.10.10.0/24, try:
ip policy-class NAT-VoIP
allow list MATCH-PRIVATE-VoIP
allow list MATCH-PRIVATE-VoIP self
nat source list MATCH-ALL interface eth 0/1.23 overload
The keyword "self" permits traffic to the router itself but not to hosts on the interface.
You could also do
allow list MATCH-PRIVATE-VoIP policy NAT-VoIP
but I think the allow list minus keyword self should be fine.
What does your NAT-VoIP access policy look like? Is IP routing enabled on the 3448? Can you ping between a device on vlan 6 and one on vlan 7?
Jay, i believe you are onto something here...we are looking into the NAT-VoIP policy to see how to open access between these two vlans. any insight would be appreciated. thanks.
interface eth 0/1
description WAN Uplink
encapsulation 802.1q
no shutdown
!
interface eth 0/1.21
description WAN Inet
vlan-id 21
ip address dhcp
ip access-policy PUBLIC-WAN
no awcp
no shutdown
interface eth 0/1.23
description WAN VoIP
vlan-id 23
vrf forwarding VoIP
ip address dhcp
ip access-policy PUBLIC-WAN
media-gateway ip primary
qos-policy in SET-DSCP-WAN
no awcp
no shutdown
!
interface eth 0/2
no ip address
shutdown
ip policy-class NAT-Data
allow list MATCH-PRIVATE-Data self
nat source list MATCH-ALL interface eth 0/1.21 overload
!
ip policy-class NAT-VoIP
allow list MATCH-PRIVATE-VoIP self
nat source list MATCH-ALL interface eth 0/1.23 overload
!
ip policy-class PUBLIC-WAN
allow list ADMIN-ACCESS self
allow list VoIP-INBOUND self
Assuming that MATCH-PRIVATE-VoIP contains both 10.10.7.0/24 and 10.10.10.0/24, try:
ip policy-class NAT-VoIP
allow list MATCH-PRIVATE-VoIP
allow list MATCH-PRIVATE-VoIP self
nat source list MATCH-ALL interface eth 0/1.23 overload
The keyword "self" permits traffic to the router itself but not to hosts on the interface.
You could also do
allow list MATCH-PRIVATE-VoIP policy NAT-VoIP
but I think the allow list minus keyword self should be fine.
Jay, Appreciate the input here....using the line allow list MATCH-PRIVATE-VoIP policy NAT-VoIP worked.....using the other two lines together only allowed outside audio to flow, but if i used the line without "self" inside calls between netwrks flowed but not outside.