Greetings everyone,
I have NetVanta 3430 router connected to T1 and few IP phones connecting to asterisk PBX in the cloud behind it.
I'm switching to new PBX and the issue I encountered is that with new PBX I can register one phone and it will work fine, but if I add second phone it registers and within few minutes becomes unreachable.
I ruled out issue with PBX by registering phones from different location.
Attached is config with some settings removed for security.
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
name-server 8.8.8.8
!
no auto-config
!
event-history on
no logging forwarding
logging forwarding priority-level info
no logging email
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
no ip firewall alg sip
!
no dot11ap access-point-control
!
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp excluded-address
!
ip dhcp pool "VoIP"
network x.x.x.x x.x.x.x
dns-server 8.8.8.8 208.67.222.222
default-router x.x.x.x
lease 8
!
ip dhcp pool "VoIP2"
network x.x.x.x255.255.255.0
dns-server 8.8.8.8 208.67.222.222
default-router x.x.x.x
lease 8
!
no ethernet cfm
!
interface loop 1
ip address x.x.x.x x.x.x.x
no shutdown
!
interface eth 0/1
encapsulation 802.1q
no shutdown
!
interface eth 0/1.1
vlan-id 2
ip address x.x.x.x x.x.x.x
ip access-policy Private
no shutdown
interface eth 0/1.5
description VoIP
vlan-id 5
ip address x.x.x.x255.255.255.0
ip mtu 1500
ip access-policy Private
no shutdown
!
interface eth 0/2
no ip address
shutdown
no lldp send-and-receive
!
interface t1 1/1
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface ppp 1
ip address x.x.x.x x.x.x.x
ip access-policy Public-Fwd
no lldp send-and-receive
no shutdown
cross-connect 1 t1 1/1 1 ppp 1
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
ip access-list extended Management
permit ip x.x.x.x x.x.x.x any
permit ip x.x.x.x x.x.x.x any
permit ip x.x.x.x x.x.x.x any
permit ip any any
!
ip access-list extended PortFwd
permit tcp any host x.x.x.x eq 2022 log
!
ip access-list extended self
remark Traffic to NetVanta
permit ip any any log
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface ppp 1 overload
!
ip policy-class Public
allow list Management
allow list Management self
!
ip policy-class Public-Fwd
nat destination list PortFwd address x.x.x.x port 22
allow list Management self
!
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
no tftp server
no tftp server overwrite
http server
http secure-server
no snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
sip udp 5060
sip tcp 5060
jayh, sorry for getting back so late.
The suggested settings did not work.
Phones register registers and within minute unregistered itself.
Try the following:
ip firewall alg sip
!
sip proxy
sip proxy transparent
!
ip rtp symmetric-filter
!
interface eth 0/1.5
media-gateway ip primary
!
interface ppp 1
media-gateway ip primary
jayh, sorry for getting back so late.
The suggested settings did not work.
Phones register registers and within minute unregistered itself.