I can't seem to figure out how to set up multiple VLANs on a single switchport, here's the configuration I've come up with:
ip dhcp pool "VLAN1"
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
ip dhcp pool "VLAN2"
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
ip dhcp pool "VLAN3"
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
interface eth 0/1
ip address dhcp
no shutdown
interface eth 0/2
ip address dhcp
no shutdown
interface switchport 0/1
no shutdown
switchport mode trunk
switchport trunk allowed vlan 1-3
interface vlan 1
ip address 192.168.1.1 255.255.255.0
no shutdown
interface vlan 2
ip address 192.168.2.1 255.255.255.0
no shutdown
interface vlan 3
ip address 192.168.3.1 255.255.255.0
no shutdown
It appears to be working somewhat, I always get the Native VLAN information. I have a Netgear switch with the following setup:
VLAN 1:
Untagged: 1-24
VLAN 2:
Tagged: 1
Untagged: 2-12
VLAN 3:
Tagged: 1
Untagged: 13-24
I'm coming from a Cisco background, which I can do this setup very easily with Cisco equipment, but for whatever reason I'm having difficulties with getting it working properly on the Adtran/Netgear set up.
Thank you for your help!
Hi python09:
Thanks for posting your question in the Support Community! I think you're very close with this configuration. I don't see any problem with the 3448 config. The Netgear switch appears to have VLAN 1 untagged for all 24 ports, but VLANs 2 and 3 are also untagged for their respective ranges. I recommend using Netgear's "advanced" or 802.1Q configuration options. If I recall correctly, you need to (a) set the default VLAN membership for each port (VLAN 1 for port 1; VLAN 2 for ports 2-12; VLAN 3 for ports 13-24). And (b) setup VLAN 1 to be untagged only on the trunk port--port 1--and make it tagged for 2-24. Leave VLAN 2 untagged for 2-12, and VLAN 3 untagged for 13-24, as you have it listed.
Best,
Chris
Hi python09:
Thanks for posting your question in the Support Community! I think you're very close with this configuration. I don't see any problem with the 3448 config. The Netgear switch appears to have VLAN 1 untagged for all 24 ports, but VLANs 2 and 3 are also untagged for their respective ranges. I recommend using Netgear's "advanced" or 802.1Q configuration options. If I recall correctly, you need to (a) set the default VLAN membership for each port (VLAN 1 for port 1; VLAN 2 for ports 2-12; VLAN 3 for ports 13-24). And (b) setup VLAN 1 to be untagged only on the trunk port--port 1--and make it tagged for 2-24. Leave VLAN 2 untagged for 2-12, and VLAN 3 untagged for 13-24, as you have it listed.
Best,
Chris