I'm pretty sure I can use my AdTran 3430 as a DHCP server. I also see where it can do DNS lookups. I plan to use OpenDNS as my primary DNS server. However, I don't know if local machines will still require a local DNS server. Right now we are almost 100% cloud based, so the only thing my servers (Apple) are doing is DHCP and DNS lookups. If I could offload that to my 3430, I could get rid of those two servers and be totally server free (w00t!)
Is that possible?
Yeah, I know about the eggs in the basket thing, but I WOULD prefer to put all my eggs in one basket - and watch it like a hawk.
Thanks,
John
Absolutely you can do this.
Here are a few config snippets I have on my office 3130 which acts as my DHCP server but also my DNS proxy for my local devices. (These features are available on all Adtran routers).
Enable the domain proxy and specify the upstream OpenDNS servers.
(Added from the Configure Terminal mode - WebGui instructions are below).
!
domain-proxy
name-server 208.67.222.222 208.67.220.220
!
Create a DHCP pool for my LAN interface... (Pointing my clients to the Adtran router for DNS).
!
ip dhcp pool "Home-LAN"
network 192.168.1.0 255.255.255.0
dns-server 192.168.1.254
default-router 192.168.1.254
ntp-server 192.168.1.254
!
The above values match the IP information on my LAN interface which looks like this...
interface vlan 1
ip address 192.168.1.254 255.255.255.0
ip access-policy Private
no shutdown
!
This can all be done via the WebGUI also.
The domain proxy and DNS servers are configured and enabled under the SYSTEM->Hostname/DNS tab.
The DHCP scope can be created under the SYSTEM->DHCP Server tab. Just type the name of the pool, click Add and add the required bits (Subnet Address, mask and default gateway are required fields, then the DNS servers are configured on the 'Optional configuration' tab. You want the DNS server in the DHCP scope to be the IP address of the LAN facing interface to allow the DNS proxy to do its thing.
Absolutely you can do this.
Here are a few config snippets I have on my office 3130 which acts as my DHCP server but also my DNS proxy for my local devices. (These features are available on all Adtran routers).
Enable the domain proxy and specify the upstream OpenDNS servers.
(Added from the Configure Terminal mode - WebGui instructions are below).
!
domain-proxy
name-server 208.67.222.222 208.67.220.220
!
Create a DHCP pool for my LAN interface... (Pointing my clients to the Adtran router for DNS).
!
ip dhcp pool "Home-LAN"
network 192.168.1.0 255.255.255.0
dns-server 192.168.1.254
default-router 192.168.1.254
ntp-server 192.168.1.254
!
The above values match the IP information on my LAN interface which looks like this...
interface vlan 1
ip address 192.168.1.254 255.255.255.0
ip access-policy Private
no shutdown
!
This can all be done via the WebGUI also.
The domain proxy and DNS servers are configured and enabled under the SYSTEM->Hostname/DNS tab.
The DHCP scope can be created under the SYSTEM->DHCP Server tab. Just type the name of the pool, click Add and add the required bits (Subnet Address, mask and default gateway are required fields, then the DNS servers are configured on the 'Optional configuration' tab. You want the DNS server in the DHCP scope to be the IP address of the LAN facing interface to allow the DNS proxy to do its thing.
OUTSTANDING!!!
Thanks, Eric!!
You are Welcome!
Were you able to get this working on your LAN? If so - don't forget to mark the Question as answered as it will help others find it in the future.
Thanks!
I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.
Thanks,
Noor
OK, I finally got up the nerve to try this.
The very first thing that happened is an Invalid subnet error.
I'm trying to configure a Class B network (I need more than 255 IP addresses).
Is this router (3430) NOT able to do Class B networks? (I know some can't but I always thought they were the cheaper NetGears and such).
If I can't set up a Class B, then I guess I have to try something different.
UPDATE: 6/18/13
After a call to tech support it turns out I misconfigured the DHCP Server Pool settings. I'm familiar with how Apple does DHCP on their OSX Server, so the "wording" of the configuration tab confused me. I needed a Class B subnet with IP addresses in the 192.168.1.1 through 192.168.3.255 range. In order to do that I needed to assign the Subnet Address as 192.168.0.0, with a subnet mask of 255.255.252.0 (which is the subnet mask I'm using now). I set the router as the Default Gateway (192.168.1.1) and set OpenDNS as my Primary and Secondary DNS.
I excluded the 192.168.0.x part of the network and the first 50 IP addresses of the 192.168.1.x network since they are statically assigned.
As soon as I figure out the DNS part, I'm going to shut that down on my Mac Minis as well.
I turned on DHCP last night (turned it off on my Mac Mini) and this morning the router is handing out IP addresses just fine. So far, so good!!
UPDATE: 6/20/13
Well, got DNS working as well - I am a happy camper. Just retired my last two servers. I have one NAS array I use for Time Machine backups of the Admin staff and, maybe, some local storage for next year. But that's it. A router, two controllers (for wireless redundancy) and the NAS. Running 200+ devices - all is good!