Hello,
I am replacing an old Cisco router at a customer site and since I've never configured ADSL on an AdTran product I need a little assistance. I'll be using a NetVanta 3458 with an ADSL NIM
Related part of existing Cisco Config:
interface ATM1/0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface Dialer1
description ---------------------------------- ppoe dialer for ADSL connection
ip address negotiated
ip mtu 1490
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer remote-name redback
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname dsluser
ppp chap password 7 encrypteddslpass
ppp pap sent-username dsluser password 7 encrypteddslpass
What I think I need to do in the NetVanta:
interface adsl 2/1
no shutdown
!
!
interface atm 1 point-to-point
no shutdown
cross-connect 2 adsl 2/1 atm 1
!
interface atm 1.1 point-to-point
no shutdown
pvc 0/35
no ip address
!
interface ppp 1
ip address negotiated
ip access-policy all-selfprotect
ppp authentication chap
no fair-queue
ppp chap hostname dsluser
ppp chap password encrypted encrypteddslpass
no shutdown
cross-connect 3 atm 1.1 ppp 1 pppoe-client
Any help is greatly appreciated.
- I believe you opened a support ticket with Adtran Technical Support where it was determined that the PPPoE connection was unable to come up due to the mismatch PPP negotiation settings between the NetVanta and the Cisco router it was negotiating with.
The Cisco router was set to negotiate the PPP connection using CHAP. This means that the NetVanta would need to send a username and password through CHAP to the Cisco to authenticate the VPN connection. The NetVanta configuration settings based on your configuration above would need to look something like this:
interface ppp 1
ip address negotiated
ip access-policy all-selfprotect
no fair-queue
ppp chap hostname dsluser
ppp chap password encrypted encrypteddslpass
no shutdown
cross-connect 3 atm 1.1 ppp 1 pppoe-client
Note that the ppp authentication chap command was removed from the configuration you provided. This command will actually require the Cisco to authenticate to the NetVanta, which will cause issues if the Cisco is not sending a CHAP username and password.
Are you having any additional issues with your setup? Please let us know if you have any further questions.
Thanks,
Noor
@mmarkwood - Your sample NetVanta configuration looks correct. The ADSL interface will cross-connect with the ATM interface and the ATM sub-interface will cross-connect with the PPP interface, as you have already configured.
The following guides provide more details on how to set up ADSL and PPPoE connections:
Configuring PPP and PPPoE over ATM in AOS Quick Start Guide
If you are experiencing issues bringing the connection up, it would be helpful to see the following:
1. Output to "show interface".
2. Output to "debug ppp verbose" as the PPP connection negotiates.
**Note: I would recommend logging the output of this debug
Please do not hesitate to let us know if you have any questions.
Thanks,
Noor
3. A copy of the configuration. Please remember to remove any information that may be sensitive to your network.
- I believe you opened a support ticket with Adtran Technical Support where it was determined that the PPPoE connection was unable to come up due to the mismatch PPP negotiation settings between the NetVanta and the Cisco router it was negotiating with.
The Cisco router was set to negotiate the PPP connection using CHAP. This means that the NetVanta would need to send a username and password through CHAP to the Cisco to authenticate the VPN connection. The NetVanta configuration settings based on your configuration above would need to look something like this:
interface ppp 1
ip address negotiated
ip access-policy all-selfprotect
no fair-queue
ppp chap hostname dsluser
ppp chap password encrypted encrypteddslpass
no shutdown
cross-connect 3 atm 1.1 ppp 1 pppoe-client
Note that the ppp authentication chap command was removed from the configuration you provided. This command will actually require the Cisco to authenticate to the NetVanta, which will cause issues if the Cisco is not sending a CHAP username and password.
Are you having any additional issues with your setup? Please let us know if you have any further questions.
Thanks,
Noor
Noor
You are correct. I worked with support to determine the problem which wound up being that extra line in the config.