Hello,
I currently have a NetVanta 3305 Router installed at two locations using the HDLC Interface (T1) and Eth 0/1 to create a dedicated connection between offices. Both Locations have internet access so I setup the default route to use the local internet router at each location to keep any internet traffic off the connection. With Comcast Metro-E in our area, I would now like to use Eth 0/2 on both routers to create a "Faster" connection between buildings and use the HDLC interface as a failover backup until our contract runs out on the T1. By creating another static route using a lower metric, in this case a 1 for the Eth 0/2 interface, I understand that the router will use the lower "cost" route to send traffic across. However, since this is an Ethernet interface, It appears that I need to setup a network monitor to monitor communication between the Eth 0/2 interfaces to have it failover to the DHLC interface in the event comms fail on Eth 0/2 and that I would need to do this for each router? Am I correct on this is there a better way to do this? Thanks for any feedback.
Location 1
0.0.0.0 | 0.0.0.0 | 10.0.0.1 | 1 | Static | |
10.0.0.0 | 255.255.255.0 | 0.0.0.0 | 0 | Connected | |
10.10.10.0 | 255.255.255.0 | 0.0.0.0 | 0 | Connected | |
10.10.20.0 | 255.255.255.0 | 0.0.0.0 | 0 | Connected | |
192.168.0.0 | 255.255.255.0 | 10.10.10.20 | 10 | Static |
Location 2
Destination | Mask | Next Hop | Dist | Type | |
0.0.0.0 | 0.0.0.0 | 192.168.0.10 | 1 | Static | |
10.0.0.0 | 255.255.255.0 | 10.10.10.10 | 10 | Static | |
10.10.10.0 | 255.255.255.0 | 0.0.0.0 | 0 | Connected | |
10.10.20.0 | 255.255.255.0 | 0.0.0.0 | 0 | Connected | |
192.168.0.0 | 255.255.255.0 | 0.0.0.0 | 0 | Connected |
Thank you for asking this question in the support community. If you review the WAN Failover Using Network Monitor guide, it is similar to this application, except it incorporates the firewall as well (which it sounds like you do not need). When following the configuration guide, you could just substitute the Ethernet 0/2 port (metro-e) from your application in place of the "Internet" port in the guide, as well as remove the firewall portions. Here is an example:
ip local policy route-map LOCAL
!
interface eth 0/2
ip address <WAN1 IP Address> <WAN1 Subnet Mask>
!
probe WAN1 icmp-echo
destination <WAN1 Gateway IP>
source <WAN1 IP Address>
period <interval between tests (seconds)>
tolerance consecutive fail <# needed to fail> pass <# needed to pass>
no shutdown
!
track WAN1
test if probe WAN1
no shutdown
!
ip access-list extended WAN1
permit icmp host <WAN1 IP Address> host <WAN1 Gateway IP>
!
route-map LOCAL permit 10
match ip address WAN1
set ip next-hop <WAN1 Gateway IP>
set interface null 0
!
ip route 192.168.0.0 255.255.255.0 <WAN1 Gateway IP> track WAN1
ip route 192.168.0.0 255.255.255.0 <WAN2 Gateway IP over the T1> 10
I hope this example configuration makes sense, but please do not hesitate to reply to this post with additional questions or information. I will be happy to help in any way I can.
Levi
Thank you for asking this question in the support community. If you review the WAN Failover Using Network Monitor guide, it is similar to this application, except it incorporates the firewall as well (which it sounds like you do not need). When following the configuration guide, you could just substitute the Ethernet 0/2 port (metro-e) from your application in place of the "Internet" port in the guide, as well as remove the firewall portions. Here is an example:
ip local policy route-map LOCAL
!
interface eth 0/2
ip address <WAN1 IP Address> <WAN1 Subnet Mask>
!
probe WAN1 icmp-echo
destination <WAN1 Gateway IP>
source <WAN1 IP Address>
period <interval between tests (seconds)>
tolerance consecutive fail <# needed to fail> pass <# needed to pass>
no shutdown
!
track WAN1
test if probe WAN1
no shutdown
!
ip access-list extended WAN1
permit icmp host <WAN1 IP Address> host <WAN1 Gateway IP>
!
route-map LOCAL permit 10
match ip address WAN1
set ip next-hop <WAN1 Gateway IP>
set interface null 0
!
ip route 192.168.0.0 255.255.255.0 <WAN1 Gateway IP> track WAN1
ip route 192.168.0.0 255.255.255.0 <WAN2 Gateway IP over the T1> 10
I hope this example configuration makes sense, but please do not hesitate to reply to this post with additional questions or information. I will be happy to help in any way I can.
Levi
I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.
Thanks,
Levi