Hi all, I have a new Netvanta 1560 running 4.4-43, and I'm trying to see if it would be useful to me as a small branch office WAN L3 switch. The Metro-E carrier requires that all traffic handed off to the WAN be marked with CoS 3 or 5. Our standard is all normal traffic is marked as "3", and all VoIP traffic is marked as "5". Any traffic not marked with CoS or marked with anything but 3 or 5 goes into the scavenger traffic tier. Below is an equivalent Cisco config. Can I do something similar with the Adtran? I have a ticket open with Adtran, but I don't have a service plan, so I'm not sure what response I'll get. I'll post any updates to this topic that I get from Adtran.
class-map match-any PREMIUM
match dscp cs5
match dscp ef
match dscp cs6
match dscp cs7
policy-map CARRIER
class PREMIUM
set cos 5
class class-default
set cos 3
interface GigabitEthernet1/0/1
description \\ Link to METRO-E WAN //
switchport trunk allowed vlan 681
switchport mode trunk
service-policy output CARRIER
interface Vlan681
bandwidth 100000
ip address x.x.x.x
ip ospf 1 area 0
I'll also add that on some older Cisco switches that I use as WAN branch office switches, the above doesn't work, and I have to do a custom DSCP-to-CoS map, but that's not my preferred solution, since it's not as fine-grained as the approach above. I mention this, because it looks to me as I dig through the CLI that the Adtran offers a similar way to perform a custom DSCP-to-CoS mapping.
mls qos map dscp-cos 0 1 2 3 4 5 6 7 to 3
mls qos map dscp-cos 8 9 10 11 12 13 14 15 to 3
mls qos map dscp-cos 16 17 18 19 20 21 22 23 to 3
mls qos map dscp-cos 32 33 34 35 36 37 38 39 to 3
mls qos map dscp-cos 49 50 51 52 53 54 55 57 to 3
mls qos map dscp-cos 58 59 60 61 62 63 to 3
mls qos map dscp-cos 48 56 to 5
Update: Adtran support recommends that I re-mark CoS based on DSCP on the ingress port as needed, since it cannot re-mark on the egress port. Sample config for a port with a VoIP phone and a PC plugged into the VoIP phone:
qos qce 1 interface GigabitEthernet 1/2-9 frame-type ipv4 dscp 46 action cos 5
qos qce 2 interface GigabitEthernet 1/2-9 frame-type ipv4 dscp 0 action cos 3
TIA,
Brian