I would like to assign an IP address to a port on a 1638. Does NetVanta support this?
Hi bigleague:
The technique I think you'll want to use is to create a new VLAN IP interface, then hard-set one or more switchports in that VLAN (access port, or port-based VLAN). Here's a sample configuration that includes the commands you need, with VLAN 2 as the example. Cheers!
CJ
!
vlan 2
name "Network 2"
!
!
interface gigabit-switchport 0/20
description Network 2
no shutdown
switchport access vlan 2
!
interface gigabit-switchport 0/21
description Network 2
no shutdown
switchport access vlan 2
!
!
interface vlan 2
description Network 2
ip address 172.16.2.1 255.255.255.0
no shutdown
!
end
Hi bigleague:
The technique I think you'll want to use is to create a new VLAN IP interface, then hard-set one or more switchports in that VLAN (access port, or port-based VLAN). Here's a sample configuration that includes the commands you need, with VLAN 2 as the example. Cheers!
CJ
!
vlan 2
name "Network 2"
!
!
interface gigabit-switchport 0/20
description Network 2
no shutdown
switchport access vlan 2
!
interface gigabit-switchport 0/21
description Network 2
no shutdown
switchport access vlan 2
!
!
interface vlan 2
description Network 2
ip address 172.16.2.1 255.255.255.0
no shutdown
!
end
Thanks for the quick response. I understand how to do it with VLANs however, I was just looking for a cleaner way. So am I correct in assuming the answer is no?
To my knowledge, switchports cannot be used as Ethernet interfaces, strictly speaking. VLAN interfaces must be used.
Best,
CJ
I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.
Thanks,
Levi