Port connects to MOE network that requires correct VLAN tag.
!
interface gigabit-switchport 0/5
no shutdown
switchport mode trunk
switchport trunk allowed vlan 2
!
end
sh ru int gig 0/5 v
Building configuration...
!
!
interface gigabit-switchport 0/5
description
alias
speed auto
no flowcontrol
mac-address 00:A0:C8:45:B2:2F
snmp trap link-status
power inline auto
spanning-tree cost 0
spanning-tree port-priority 128
spanning-tree bpdufilter disable
spanning-tree bpduguard disable
no spanning-tree edgeport
spanning-tree link-type auto
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk native vlan 1
switchport trunk allowed vlan 2
no switchport voice vlan
no switchport guest-voice vlan
no switchport voice-signaling vlan
no switchport softphone vlan
switchport trunk fixed vlan none
no storm-control broadcast level
no storm-control multicast level
no storm-control unicast level
no storm-control action shutdown
qos default-cos 0
no qos trust cos
no switchport port-security
switchport port-security aging time 0
switchport port-security aging type absolute
no switchport port-security aging static
switchport port-security maximum 1
switchport port-security violation shutdown
no switchport port-security mac-address sticky
switchport port-security expire time 0
switchport port-security expire type absolute
no switchport protected
no switchport gvrp
lldp send-and-receive
lldp send port-description
lldp send system-name
lldp send system-description
lldp send system-capabilities
lldp send management-address
lldp send med-info network-policy
lldp send 802.3-info mac-phy-config
port-auth port-control force-authorized
port-auth auth-mode port-based
port-auth control-direction in
no port-auth multiple-hosts
!
end
brian_ctl:
Thank you for asking this question, as well as providing the configuration for reference. Currently, AOS does not have a way to explicitly prevent the native VLAN from traversing a trunk port. It has to be done a little differently. To prevent this traffic on the ADTRAN, perform the following steps to the trunk port configuration:
1.) Allow the desired VLAN to be sent out the trunk port.
2.) Create an unused VLAN as the native VLAN on the trunk (this will prevent the default native VLAN 1 from being allowed out the trunk port).
interface switchport 0/1
no shutdown
switchport mode trunk
switchport trunk native vlan <RANDOM VLAN ID NOT IN USE>
switchport trunk allowed vlan 2
I hope that makes sense, but please do not hesitate to reply to this post with additional information or questions. I will be happy to help in any way I can.
Levi
brian_ctl:
Thank you for asking this question, as well as providing the configuration for reference. Currently, AOS does not have a way to explicitly prevent the native VLAN from traversing a trunk port. It has to be done a little differently. To prevent this traffic on the ADTRAN, perform the following steps to the trunk port configuration:
1.) Allow the desired VLAN to be sent out the trunk port.
2.) Create an unused VLAN as the native VLAN on the trunk (this will prevent the default native VLAN 1 from being allowed out the trunk port).
interface switchport 0/1
no shutdown
switchport mode trunk
switchport trunk native vlan <RANDOM VLAN ID NOT IN USE>
switchport trunk allowed vlan 2
I hope that makes sense, but please do not hesitate to reply to this post with additional information or questions. I will be happy to help in any way I can.
Levi
That is the workaround I was using, just wanted to make sure I wasn't missing something.
Thanks
brian_ctl:
I marked this post as "assumed answered," but do not hesitate to reply with further questions.
Levi
I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.
Thanks,
Levi