Hello everyone, I'm new to this so please bear with me!
We have a Windows 2003 Server with 2 scopes 10.122.143.x and 10.10.1.x. We have 3 seperate buildings linked together, so we have 3 1224st's that we need to setup with a VLAN so that it can grab the 10.10.1.x IP's for the phones and 10.122.143.x for everything else. I've been playing around, and I can't seem to get a grasp on how the configuration file should be setup.
I've attached it so that you guys can take a look. What we want is
VLAN 2 to be the voice_network and VLAN 3 to be the user_network. Right now, when I have a port left as Trunk, I can't get any DHCP address. I have to set it up as Trunk with native being vlan 2. I also can't pink the switch so I can't connect to it over the network, I have to use the serial cable. Just any help would be greatly appreciated!!!
Remove the command ip host "swleh101" 10.10.1.4 by entering the command again with the no keyword in front of it like this: no ip host "swleh101" 10.10.1.4. That command is not needed in this design.
The command ip default-gateway 10.10.1.1 will allow you to manage the switch when you are on a different subnet because the switch will send the traffic to the default-gateway (router) to route the traffic appropriately.
To manage the ADTRAN switch you will need this in the configuration:
interface vlan 2
ip address 10.10.1.4 255.255.255.0 <--this sets the web interface IP address
no shutdown
You will not set the DNS servers on the switch. Typically this is handled by a router, or the DHCP server.
Levi
Thank you for asking this question in the support community. These previous posts may provide you with some beneficial information about the common design for this application:
https://supportforums.adtran.com/message/3044#3044
https://supportforums.adtran.com/message/2632#2632
In addition to some of the questions that you should answer from those previous posts, are the phones tagging the traffic with VLAN 2? What IP address subnet and VLAN do you want to manage the switches on?
Please, reply to this post with additional information and questions. I will be happy to help in any way I can.
Levi
The phones should be tagging traffic with VLAN 2, but we haven't gotten to that point I guess. From options 156 on the DHCP server, it is supposed to tag it with VLAN 2. But maybe this is where I'm getting confused at.
I would like to be able to manage the switch on the 10.10.1.4.
I did read through those other posts before, and I can "create" a VLAN, but it just doesn't seem to accomplish what we're trying to do. I see the terms such as 'switchport access vlan' and 'switchport access mode', but I can't really find out what each one does. And every setup I refer to seems to lead me in a different direction.
Thanks!
Often, phones will initially boot up in the native VLAN (1 in most cases), requesting an address via DHCP. In your case, the phones will request a DHCP address with options. The DHCP server will receive this DHCP DISCOVERY message with options, and then tell the phones to reboot into the desired VLAN (VLAN 2 in your case). Furthermore, if the PCs are connected to the phones, and then the phones connect to the switch, the switchports on the switch should be configured as trunks, which will allow multiple VLANs (both phones and PCs) to traverse the link. The command switchport mode trunk configures the port in trunking mode.
To test your configuration, I would recommend setting up something similar to this:
interface eth 0/4
no shutdown
switchport mode trunk
interface eth 0/5
no shutdown
switchport mode trunk
With this configuration, the PC should obtain an IP address from the DHCP server, and the phone should receive an IP address from the DHCP server, which then instructs it to reboot into a new VLAN.
As mentioned in the previous linked post, the VLAN interface is for management purposes (i.e. logging into the unit via telnet, SSH, HTTP, or HTTPS for configuration changes and troubleshooting; there can be only one active VLAN interface on the unit). Therefore, the only interface vlan command that should be configured on the unit should be for the management VLAN's IP address. I believe in your case it would be similar to this:
interface vlan x (where x represents the management VLAN ID)
ip address 10.10.1.4 255.255.255.0
no shutdown
Please, do not hesitate to reply and let me know what additional questions you have.
Levi
Okay, here's what I got so far...
ip host "swleh101" 10.10.1.4 <---this is what the IP address is of the switch? Should this be the same as the web interface?
ip domain-name "lehi.local"
ip default-gateway 10.10.1.1 <--- this is our watchguard router
interface eth 0/4
no shutdown
switchport mode trunk
!
interface eth 0/5
no shutdown
switchport mode trunk
!
interface eth 0/6
no shutdown
switchport mode trunk
switchport trunk native vlan 2
!
interface eth 0/7
no shutdown
switchport mode trunk
switchport trunk native vlan 3
!
interface eth 0/8
no shutdown
switchport mode trunk
switchport access vlan 2
!
With it setup like this, I can connect to the web interface of
eth 0/6 and eth 0/8 with a direct connection. Any other connection I use will not connect to the web interface. This is while setting my IP to 10.10.1.101 sub:255.255.255.0 router:10.10.1.1
also, do I need to include this?
!
interface vlan 1
no ip address
shutdown
interface vlan 2
ip address 10.10.1.4 255.255.255.0 <--this sets the web interface correct?
no shutdown
!
It was on one of the backup configs so I copied it over. Is there a setting for telling the switch where the DNS server is? Ours is on 10.122.143.10, but I don't know if that needs to be specified somewhere.
Thanks for all your help!!!
Remove the command ip host "swleh101" 10.10.1.4 by entering the command again with the no keyword in front of it like this: no ip host "swleh101" 10.10.1.4. That command is not needed in this design.
The command ip default-gateway 10.10.1.1 will allow you to manage the switch when you are on a different subnet because the switch will send the traffic to the default-gateway (router) to route the traffic appropriately.
To manage the ADTRAN switch you will need this in the configuration:
interface vlan 2
ip address 10.10.1.4 255.255.255.0 <--this sets the web interface IP address
no shutdown
You will not set the DNS servers on the switch. Typically this is handled by a router, or the DHCP server.
Levi
I think I have it all setup like it should be. We're going to remove the temporary switch that's in place and test it out.
Thanks for your help!