I'm sure this has been asked and answered many times but I could not find anything in a quick search.
I've inherited a simple network that had a T1, connected to the WAN-T1 port on the back of a NetVanta 1224R switch, and a single device in port 1 of the switch that controls a billboard. (all configuration changes done on a laptop I connected to port 17 if it matters) The company cancelled the T1 and got a fiber connection instead, but did not look at the other devices to see what changes would be needed. They just called me when the billboard lost connectivity.
I tried to just switch the cat5 running to the back of the unit to the new fiber switch instead of the t1 smartjack. However when I went into the configuration page to reconfigure it that port seems to be "T1 1/1" and only supports T1 settings, (limited speed and such)
I then tried to reconfigure port 24 to be the 'default' VLAN and configuring it's static IP to be the one provided for the fiber connection, but I could not ping the gateway IP. (I could ping the static IP I configured on that port.)
My question is, which is the better solution. Is there a way to force the "Wan-T1" port on the back to be standard ethernet? Is there a way to make port 24 the "WAN" port and route traffic through that? I'm ok with either solution, but currently can't get either to work. Is it possible or do I need a new switch/router instead?
Any help would be appreciated.
Charles this topic is covered in this thread VLan & Routing and here is a link to the config guide Configuring InterVLAN Routing in AOS - Quick Configuration Guide
Sorry, but you cannot reconfigure a T1 port to be an Ethernet port. Despite the fact they are both RJ45 plug connections, T1 (if that's a plugin card in your switch) hardware operates on different physical and electrical principles and protocols. You would need to configure a vlan interface first and apply an IP address to the interface. Then you would need to build a port as an access port and allow that vlan on that port. IE - switchport access vlan 100. That physical switchport now becomes your wan connection to the world.
I removed the t1 card once I learned it could not be used for ethernet.
The netvanta router automatically made port 1 the internet port so I made that the devault vlan and configured the ip on it. I put the cord to the billboard on port 2 and my laptop on 16.
I can now ping both the ip on the netvanta and the gateway, however I cannot reach the internet.
! blanked out a couple secure passwords but otherwise here is the current config.
!
!
! ADTRAN, Inc. OS version 13.02.00
! Boot ROM version 06.03.00
! Platform: NetVanta 1224R, part number 1200510L1
! Serial number LBADTN0446AA603
! Flash: 16777216 bytes DRAM: 33554431 bytes
! Date/Time: Thu Dec 08 2016, 14:20:18 EST
!
!
hostname "Switch"
enable password password
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip domain-proxy
ip host "connie-lenovo" 192.168.0.5
ip domain-name "zoomtown.com"
ip name-server 216.68.1.100 8.8.8.8
ip routing
!
no auto-config
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "admin" password "password"
username #############################
!
banner motd #
****** Important ******
Enable and Telnet passwords are configured to "password".
Please change them immediately.
The vlan 1 interface is enabled with an address of 10.10.10.1
Telnet access is also enabled.
#
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg h323
!
!
!
!
!
!
!
!
!
!
ip dhcp-server pool "internal"
network 192.168.0.0 255.255.255.0
domain-name "zoomtown.com"
dns-server 192.168.0.1
netbios-node-type h-node
default-router 192.168.0.1
!
!
!
vlan 1
name "Default"
vlan 100
name "VLAN0100"
!
interface eth 0/1
description External Interface to ISP
speed 10
spanning-tree edgeport
no shutdown
!
interface eth 0/2
spanning-tree edgeport
no shutdown
switchport access vlan 100
!
interface eth 0/3
no shutdown
switchport access vlan 100
!
interface eth 0/4
no shutdown
switchport access vlan 100
!
interface eth 0/5
no shutdown
switchport access vlan 100
!
interface eth 0/6
no shutdown
switchport access vlan 100
!
interface eth 0/7
no shutdown
switchport access vlan 100
!
interface eth 0/8
no shutdown
switchport access vlan 100
!
interface eth 0/9
no shutdown
switchport access vlan 100
!
interface eth 0/10
no shutdown
switchport access vlan 100
!
interface eth 0/11
no shutdown
switchport access vlan 100
!
interface eth 0/12
no shutdown
switchport access vlan 100
!
interface eth 0/13
no shutdown
switchport access vlan 100
!
interface eth 0/14
no shutdown
switchport access vlan 100
!
interface eth 0/15
no shutdown
switchport access vlan 100
!
interface eth 0/16
spanning-tree edgeport
no shutdown
switchport access vlan 100
!
interface eth 0/17
no shutdown
switchport access vlan 100
!
interface eth 0/18
no shutdown
switchport access vlan 100
!
interface eth 0/19
no shutdown
switchport access vlan 100
!
interface eth 0/20
no shutdown
switchport access vlan 100
!
interface eth 0/21
no shutdown
switchport access vlan 100
!
interface eth 0/22
no shutdown
switchport access vlan 100
!
interface eth 0/23
no shutdown
switchport access vlan 100
!
interface eth 0/24
no shutdown
switchport access vlan 100
!
!
interface vlan 1
ip address 216.196.180.106 255.255.255.252
access-policy Public
no shutdown
interface vlan 100
ip address 192.168.0.1 255.255.255.0
access-policy Private
no shutdown
!
!
!
router rip
redistribute ospf
redistribute static
redistribute connected
network 74.202.107.52 255.255.255.252
!
!
!
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended self
remark Traffic to NetVanta
permit ip any any log
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface vlan 1 overload
!
ip policy-class Public
! Implicit discard
!
!
!
ip route 66.162.112.68 255.255.255.252 74.202.107.53
ip route 74.202.107.52 255.255.255.252 66.162.112.69
ip route 74.202.107.52 255.255.255.252 66.162.112.70
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
ip http language English
no ip snmp agent
no ip ftp server
no ip scp server
ip sntp server
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login
password ########
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
sntp server pool.ntp.org
!
!
!
!
end
Removed some old routing and rip entries. latest stripped down config I can still ping gateway but not further.
I put the external ip on laptop and tested the fiber connection. browsing works fine so not ISP isue.
!
!
! ADTRAN, Inc. OS version 13.02.00
! Boot ROM version 06.03.00
! Platform: NetVanta 1224R, part number 1200510L1
! Serial number LBADTN0446AA603
! Flash: 16777216 bytes DRAM: 33554431 bytes
! Date/Time: Thu Dec 08 2016, 15:12:00 EST
!
!
hostname "Switch"
enable password password
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip domain-proxy
ip host "connie-lenovo" 192.168.0.5
ip domain-name "zoomtown.com"
ip name-server 216.68.1.100 8.8.8.8
ip routing
!
no auto-config
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "admin" password "password"
username "##########################
!
banner motd #
****** Important ******
Enable and Telnet passwords are configured to "password".
Please change them immediately.
The vlan 1 interface is enabled with an address of 10.10.10.1
Telnet access is also enabled.
#
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg h323
!
!
!
!
!
!
!
!
!
!
ip dhcp-server pool "internal"
network 192.168.0.0 255.255.255.0
domain-name "zoomtown.com"
dns-server 192.168.0.1
netbios-node-type h-node
default-router 192.168.0.1
!
!
!
vlan 1
name "Default"
vlan 100
name "VLAN0100"
!
interface eth 0/1
description External Interface to ISP
speed 10
spanning-tree edgeport
no shutdown
!
interface eth 0/2
spanning-tree edgeport
no shutdown
switchport access vlan 100
!
interface eth 0/3
no shutdown
switchport access vlan 100
!
interface eth 0/4
no shutdown
switchport access vlan 100
!
interface eth 0/5
no shutdown
switchport access vlan 100
!
interface eth 0/6
no shutdown
switchport access vlan 100
!
interface eth 0/7
no shutdown
switchport access vlan 100
!
interface eth 0/8
no shutdown
switchport access vlan 100
!
interface eth 0/9
no shutdown
switchport access vlan 100
!
interface eth 0/10
no shutdown
switchport access vlan 100
!
interface eth 0/11
no shutdown
switchport access vlan 100
!
interface eth 0/12
no shutdown
switchport access vlan 100
!
interface eth 0/13
no shutdown
switchport access vlan 100
!
interface eth 0/14
no shutdown
switchport access vlan 100
!
interface eth 0/15
no shutdown
switchport access vlan 100
!
interface eth 0/16
spanning-tree edgeport
no shutdown
switchport access vlan 100
!
interface eth 0/17
no shutdown
switchport access vlan 100
!
interface eth 0/18
no shutdown
switchport access vlan 100
!
interface eth 0/19
no shutdown
switchport access vlan 100
!
interface eth 0/20
no shutdown
switchport access vlan 100
!
interface eth 0/21
no shutdown
switchport access vlan 100
!
interface eth 0/22
no shutdown
switchport access vlan 100
!
interface eth 0/23
no shutdown
switchport access vlan 100
!
interface eth 0/24
no shutdown
switchport access vlan 100
!
!
interface vlan 1
ip address 216.196.180.106 255.255.255.252
access-policy Public
no shutdown
interface vlan 100
ip address 192.168.0.1 255.255.255.0
access-policy Private
no shutdown
!
!
!
router rip
redistribute ospf
redistribute static
redistribute connected
!
!
!
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended self
remark Traffic to NetVanta
permit ip any any log
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface vlan 1 overload
!
ip policy-class Public
! Implicit discard
!
!
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
ip http language English
no ip snmp agent
no ip ftp server
no ip scp server
ip sntp server
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login
password ##############
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
sntp server pool.ntp.org
!
!
!
!
end
You still have not "allowed" your vlan (vlan 1) on the physical interface that is your WAN.Your config appears to be using vlan 1 to connect to your ISP, but you need to allow your physical port access to vlan 1. Edit eth 0/1 if its your WAN interface and aloow vlan 1 over it. Switchport access vlan 1
Doh, figured something simple. I'll be back onsite tomorrow morning and I'll give that a try. Thanks for all your help.
It appears to be allowed.
editing the physical interface I do not see where to set vlans.
According to your GUI screenshots, vlan 1 is allowed. however I would have expected eth 0/1 to look like this:
!
interface eth 0/1
description External Interface to ISP
spanning-tree edgeport
switchport access vlan 1
no shutdown
!
Unless you know for certain that your ISP provider is handing off to you a 10meg PHYSICAL 10BaseT interface, you're better off with setting your speed parameter to "AUTO" and not hardcoding it for 100Meg or 10Meg normally. The hardware 'speed' is not the same as the 'bandwidth' that you're paying for from your provider.