I have all the phones on a switch connected to ETH 0/1. ETH 0/2 is then be connected to the network with the ECS server. I'm trying to force the traffic through the total access.
When I disconnect ETH 0/2 the system should continue working (for logged in phones) minus voicemail and external calls should be routed through pots line on total access. But, when I do this, internal calls in progress continue even after hang up (wont disconnect automatically) and new calls cant be initiated. I've attached our config. Its seems like some traffic is not rerouting to its destination or is getting hung up somewhere. Any ideas on what I'm doing wrong? Thanks for your help.
!
!
! ADTRAN, Inc. OS version R10.10.0.E
! Boot ROM version 14.05.00.SA
! Platform: Total Access 908e (2nd Gen), part number 4242908L5
! Serial number CFG1143659
!
!
hostname "TA908e"
enable password password
!
!
!
ip subnet-zero
ip classless
ip default-gateway 10.18.100.1
ip routing
ipv6 unicast-routing
!
!
domain-proxy
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password "password"
!
banner motd #
Important
Web username/password is configured to admin/password.
Enable and Telnet passwords are configured to "password".
Please change them immediately.
The ethernet 0/1 interface is enabled with an address of 10.18.200.20
Telnet/SSH access is also enabled.
#
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
ip dhcp excluded-address 10.18.200.1
!
ip dhcp pool "ED_Pool"
network 10.18.200.0 255.255.255.0
default-router 10.18.200.20
option 66 ascii 10.20.100.6
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 10.18.200.20 255.255.255.0
media-gateway ip primary
no awcp
no shutdown
!
!
interface eth 0/2
ip address 10.18.100.98 255.255.255.0
media-gateway ip primary
no shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
!
interface fxo 0/0
no shutdown
!
interface ppp 1
no shutdown
!
!
!
!
!
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 10.18.100.1
!
ssh-server pubkey-chain
!
no tftp server
no tftp server overwrite
http server
http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
snmp-server enable traps snmp
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
voice dial-plan 1 extensions MXXX
voice dial-plan 2 local NXX-NXX-XXXX
!
!
!
!
voice codec-list List1
codec g729
codec g711ulaw
codec g722
codec g711alaw
!
!
!
voice trunk T02 type sip
sip-server primary 10.20.100.6
!
voice trunk T04 type analog supervision loop-start
did digits-transferred 4
trunk-number 1009
connect fxo 0/0
match dnis "9$" substitute "$"
match dnis "1051" substitute "1009"
rtp delay-mode adaptive
!
!
voice grouped-trunk LOCAL_SURVIVE
trunk T04
trunk T02
accept 1-NXX-NXX-XXXX cost 0
accept NXX-NXX-XXXX cost 0
accept NXX-XXXX cost 0
reject 1-800-NXX-XXXX
reject 1-888-NXX-XXXX
reject 1-877-NXX-XXXX
reject 1-866-NXX-XXXX
reject 1-855-NXX-XXXX
reject NXX-976-XXXX
reject 1-900-NXX-XXXX
reject 1-976-NXX-XXXX
!
voice ring-group 1009
type all
num-rings 4
member 1000
login-member 1000
member 1001
login-member 1001
member 1002
login-member 1002
member 1003
login-member 1003
member 1004
login-member 1004
member 1005
login-member 1005
member 1006
login-member 1006
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
sip proxy
!
sip proxy sip-server primary 10.20.100.6
sip proxy sip-server monitor
mode continuous interval 30
grammar from user 2345678910
grammar to user 2345678910
grammar request-uri user 2345678910
trap rollover
no shutdown
!
!
sip proxy emergency-call-routing proxy
sip proxy emergency-call-routing accept 911
!
sip proxy failover accept-registrations
sip proxy failover match-digits 10
sip proxy failover codec-group List1
sip proxy failover sip-keep-alive info 180
sip proxy failover trust-domain
sip proxy failover direct-inbound
sip proxy failover register-expires 120
sip proxy register rate-adaption server-expires 16000
sip proxy register rate-adaption threshold percentage 10
!
!
!
!
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
password password
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
!
!
!
end
Mr. Casariego,
Thanks for posting! This might be something we need to troubleshoot with a regular Technical Support ticket since the debug output may be extensive. However, the first thing to check would be to verify that the phones are showing up properly with "show sip proxy user". This will let us know for sure that the phones have been properly inserted in the SIP proxy database. Valid and successfully registered stateful SIP proxy users should each have a "-RS" flag in the output of the show command. Also, since you are setup for stateful mode SIP proxy, this assumes the phones register to the Adtran unit.
Once the registration and SIP proxy database has been verified, you can begin placing test calls. Typically we would run the following debug commands to look for points of failure in the call flow.
debug sip stack message
debug sip proxy routing
debug sip proxy database
debug voice verbose
debug interface fxo
Hope this helps!
David
Mr. Casariego,
I went ahead and flagged this post as "Assumed Answered". If the response on this thread assisted you, please mark it as Correct or Helpful as the case may be with the applicable buttons. This will make it visible and help other members of the community find solutions more easily. If you still need assistance, I would be more than happy to continue working with you on this - just let me know in a reply.
Thanks!
David