Thanks to all for the assistance in getting this far.
Calls are now pouring in on the SIP side, but not yet going to the PRI. I know it's a config piece, but have searched several answers and come up with different solutions.
What should I add in here to bring those calls to my PRI? (Before OBVIOUSLY restarting the firewall and turning off the ability to ftp)
! ADTRAN, Inc. OS version R14.4.1.E
! Boot ROM version R10.9.3.B2
! Platform: Total Access 908e (3rd Gen), part number 4243908F2SCTL
! Serial number CFG1492492
!
hostname "<MASKED> SIP>PRI"
enable password level 2 <MASKED>
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip default-gateway <MASKED>
ip routing
ipv6 unicast-routing
!
domain-name "local"
name-server <IP ADDRESSES MASKED>
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
portal-list "all" console ftp http-admin ssh telnet
!
username "<MASKED>" privilege 7 password "<MASKED>"
!
no ip firewall alg ftp
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg pptp
no ip firewall alg h323
!
no dot11ap access-point-control
!
interface eth 0/1
description Gig_In
ip address <IP ADDRESSES MASKED>
ip mtu 1500
no shutdown
media-gateway ip primary
!
interface eth 0/2
no ip address
shutdown
!
interface gigabit-eth 0/1
description Gig1
ip address dhcp
ip mtu 1500
no rtp quality-monitoring
no shutdown
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
description Connection to Avaya
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 0/4
shutdown
!
interface pri 1
connect t1 0/3 tdm-group 1
no shutdown
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxo 0/0
no shutdown
!
isdn-group 1
max-channels 9
connect pri 1
!
timing-source t1 0/3
!
ip route 0.0.0.0 0.0.0.0 <IP ADDRESSES MASKED>
!
no tftp server
no tftp server overwrite
http server
http session-limit 5
http secure-server
no snmp agent
ip ftp server
ip scp server
no ip sntp server
!
sip
sip udp 5060
no sip tcp
no sip tls
!
voice feature-mode network
voice forward-mode network
!
voice codec-list "Frontier SIP"
codec g711ulaw
codec g729
!
voice trunk T01 type sip
description "FRONTIER SIP"
sip-server primary <MASKED>
sip-server validation register
domain "<MASKED>"
max-number-calls 9
register <MASKED> auth-name "<MASKED>" password "<MASKED>"
codec-list "Frontier SIP" both
grammar request-uri host domain
grammar from host domain
grammar p-asserted-identity host domain
!
voice trunk T02 type isdn
description "PRI to Avaya"
resource-selection circular descending
connect isdn-group 1
rtp delay-mode adaptive
codec-list "Frontier SIP"
!
voice grouped-trunk PRI
trunk T02
accept $ cost 0
!
voice grouped-trunk SIP
trunk T01
trunk T02
accept $ cost 0
!
line con 0
login
password <MASKED>
!
line telnet 0 4
login
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
sntp server tock.usno.navy.mil
!
end
Hello TVining,
Thanks for posting!
A couple things I will point out:
1) voice grouped-trunk SIP
trunk T01
trunk T02 <-------------------------I am not sure why T02 is listed in here when that should be associated with the PRI trunk
accept $ cost 0
You might have a reason, but it sticks out and could be the problem. Check here first.
2) isdn-group 1
max-channels 9 <---------------I'm not sure how well this command works. I think the one on the SIP trunk will suffice, but keep this in mind
connect pri 1
If removing trunk T02 from the voice-grouped trunk SIP doesn't help, run these 3 debugs:
debug sip stack message
debug isdn l2-for
debug voice verbose
Scrub the debug for sensitive info and send it in.
Thanks!
Geo