Hello all,
I have a Level3 SIP fax trunk that I am trying to test before implementing for the customer if possible. All Level3 trunks do not require a SIP registration. They only give you the IP of their SIP server without a sip user/pass. The following setup works with no problem:
ASA5505 --> switch --> ATA. I have a one-to-one NAT setup on the ASA between an unused public IP and the internal ATA IP. I have an analog phone plugged into the ATA and inbound/outbound calls work fine.
I tried the same setup but with a 916e instead of the ASA:
916e --> switch --> ATA. I have a similar setup in which I have a port forward setup on the Adtran. After running several captures, the Adtran always responds with "403 Registration Required" to Level3's sip INVITE. I opened a ticket with Adtran support to explore what my options are. We ended up setting routing between two trunks that I created on the Adtran. I currently have the following setup for this test:
916e ETH 0/1 connected directly to the ISP, and ETH 0/2 is connected to the ATA. This setup ended up partially working. All outbound calls from the analog phone to my cell or desk phone work fine. When I place inbound calls from my cell, I can hear the cell ringing but the analog phone never rings. These new captures show the Adtran sending a "487 Request Terminated." From a call control perspective, the call seems like it was hung up by the caller before it was answered. It makes sense since I call from my cell, I hear ringing, but the analog phone never rings so I hang up. Currently, the issue points to reside on the ATA. Grandstream ATA support points the fingers to the Adtran. I know the ATA handles the calls fine when used with the ASA. It's hard for me to believe that the ASA handles sip better than the sip oriented 916e. Can someone please shed some light? Possible tweaks in the config? Alternative setups?
Below is the config, and I have also attached some debugs and inbound call capture.
Thanks to all in advance,
Adrian
! ADTRAN, Inc. OS version R10.9.4.E
! Boot ROM version 14.05.00.SA
! Platform: Total Access 916e (2nd Gen), part number 4242916L5
! Serial number CFG1027874
!
!
hostname "dct.test.ta916e"
enable password encrypted 3d3a2e9a3f8a8a46a6a0afb6478b64025969
!
!
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
!
domain-name "www.4dct.com"
name-server 4.2.2.2 8.8.8.8
!
!
no auto-config
auto-config authname adtran encrypted password 3c3ad81149fbeb91c4ad15db806e6abc68da
!
event-history on
no logging forwarding
no logging email
!
service password-encryption
!
username "admin" password encrypted "424509cce2f2f612584edf6f3a94425d4e9e"
username "atetu" password encrypted "222b9538d3e6038257ca2792196a551b8c23"
!
banner login %
DCT TEST TA916e
DCT Managed Network Device
UNAUTHORIZED ACCESS IS PROHIBITED!
888.404.4328
%
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
packet-capture l3fax-in-cap standard
export tftp 207.54.171.10
limit time 0
limit size 2M
match list l3fax-inbound
shutdown
!
packet-capture l3fax-out-cap standard
export tftp 207.54.171.10
limit time 0
limit size 2M
match list l3fax-outbound
shutdown
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
description EXPEDIENT WAN
ip address 207.54.171.11 255.255.255.240
ip packet-capture l3fax-in-cap
ip access-policy wan-policy
media-gateway ip primary
no shutdown
!
!
interface eth 0/2
description LAN INTERFACE
ip address 10.10.20.254 255.255.255.0
ip packet-capture l3fax-out-cap
ip access-policy lan-policy
media-gateway ip primary
no shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
interface fxs 0/1
no shutdown
...........
...........
interface fxs 0/16
no shutdown
!
!
interface fxo 0/0
no shutdown
!
!
!
!
!
!
!
!
ip access-list extended icmp-acl
permit icmp any any
!
ip access-list extended l3-sip-server-acl
permit udp host 4.55.11.225 any
permit udp any host 4.55.11.225
permit tcp host 4.55.11.225 any
permit tcp any host 4.55.11.225
!
ip access-list extended l3fax-inbound
permit ip host 4.55.11.225 any
permit ip any host 4.55.11.225
!
ip access-list extended l3fax-nat-in-acl
permit ip any host 207.54.171.11 log
!
ip access-list extended l3fax-nat-out-acl
permit ip host 10.10.20.20 any
!
ip access-list extended l3fax-outbound
permit ip host 10.10.20.20 any
permit ip any host 10.10.20.20
!
ip access-list extended nat-acl
permit ip any any
!
ip access-list extended permit-acl
permit ip any any
!
!
!
!
ip policy-class lan-policy
nat source list nat-acl interface eth 0/1 overload
allow list permit-acl
!
ip policy-class wan-policy
allow list icmp-acl
allow list l3-sip-server-acl
allow list l3fax-nat-in-acl
!
!
!
ip route 0.0.0.0 0.0.0.0 207.54.171.1
!
no tftp server
no tftp server overwrite
no http server
no http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
!
!
!
!
voice codec-list g711_only
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "Level3 Fax Trunk"
sip-server primary 4.55.11.225
domain "207.54.171.11"
codec-list g711_only both
!
voice trunk T02 type sip
description "Fax ATA"
sip-server primary 10.10.20.20
codec-list g711_only both
!
!
voice grouped-trunk T01
description "LEVEL3 SIP SERVER"
trunk T01
accept $ cost 0
!
!
voice grouped-trunk T02
trunk T02
accept 3097401198 cost 0
!
!
!
sip proxy
sip proxy transparent
!
!
!
!
line con 0
no login
line-timeout 0
!
line telnet 0 4
login local-userlist
password encrypted 262e62f350fac67818df30ef9ce2abebb767
shutdown
line ssh 0 4
login local-userlist
no shutdown
!
sntp server 23.249.x.x
!
!
!
!
end
Hello Adrian,
I found the support ticket matching this post and it looks like the ATA is not ringing the phone on the LAN because there is something it doesn't like about the INVITE sent by the ADTRAN. Have you been able to look at the ATA and see what is happening when it is processing the ADTRAN INVITE?
Regards,
Geoff
The traces clearly show that the device on 10.10.20.20 is responding with 180 Ringing and this is being relayed back to the carrier. If the analog phone never rings, I would suspect a defective ATA ring generator, a bad ringer on the analog phone, or something similar.
Do outbound calls work?
What happens if you place a call to the ATA and just pick up the analog phone after ten seconds even if it doesn't audibly ring? Can you converse?
Is it a two-line ATA and you are plugged into the wrong line?
Another option would be skipping the ATA completely and just mapping the number to an analog FXS port on the TA916.
Hi Geoff,
Thanks for the reply. I have checked the ATA numerous times. I have a ticket with their support team, and after running multiple port mirrors, the Adtran is sending a "503 Service Unavailable". Grandstream support team is blaming the Adtran at this point.
Hi Jayh,
Thanks for the reply.
- Outbound test calls work every time
- For some reason, all inbound calls now result in busy tone or "call cannot be completed"
- The ATA has two lines and I plugged the analog phone in the correct line. The other line is used for the same SIP trunk but when I have the ATA plugged into my LAN with the ASA 5505 as the gateway. Inbound and outbound calls work fine when the gateway is not an Adtran
- Skipping the ATA works fine when I'm mapping the number to an analog FXS port on the Adtran, but in some customer scenarios, having the ATA is simpler. I would really like to make this solution work. We use "less" reliable SIP carrier such as CoreDial, and those work fine with the same ATA. We want to start using Level3 fax trunks since they are true T.38 trunks. Level3 does not use SIP registrations. All they give is the SIP Signaling IP (sip server).
I added a nv3448 in my test setup. I now have: ISP - TA916 - NV3448 where the ATA and Laptop are plugged into the NV3448. I have run some fresh port mirrors this morning, and I see how the Adtran is sending "405 Method Not Allowed", and "503 Service Unavailable" during both Inbound and Outbound calls. Outbound calls still work however. Registration is unsuccessful for Inbound calling.