I have a TA908e and a PoE switch. I am able to make calls in/out (Polycom phones). When I unplug the WAN connection I am unable to make extension to extension calls. I guess my question is why the ext2ext calls won't complete. What additional setting are needed in the TA908e. Thank you in advance.
Meyerj66,
Thanks for getting us your configuration. Does your unit show SIP proxy users when you issue the "show sip proxy user" command? If not, we may not be configured for the correct SIP proxy mode. Below are the mode descriptions and the corresponding SIP proxy configuration. The configuration samples omit basic interface, firewall settings, etc. for the sake of brevity. More complete examples can be found in Configuring SIP Proxy in AOS.
Transparent Proxy Mode
The Transparent Proxy mode is best for new installations when the phone does not need to be aware of the
device presence (transparency). In this mode, the softswitch is configured as the server and the registrar
(and Outbound Proxy when required). The phones are not aware of the AOS device, and phones are not
required to use the same softswitch. Requests sent from the phones are routed to the destination IP address
of the softswitch, and the AOS device does not require configuration to be aware of the softswitch. In
Transparent Proxy mode, the softswitch address configured in the phone is the external softswitch, and SIP
signaling is sent to the Layer 3 destination address of the external softswitch.
Transparent Proxy Mode Basic Configuration
ip sip
ip sip proxy
ip sip proxy transparent
Stateful Proxy Mode
The Stateful Proxy mode is best suited for existing installations due to the ease of converting from B2BUA
to IP phones without modifying the phone configurations. In this mode, phones or user agents (UAs) rely
on the SIP server to act as the proxy, and the configuration is very similar to the existing B2BUA. The
AOS product takes on the role of proxy. The UA is not aware of other SIP servers on the network in this
mode. Each phone is configured to register to the proxy, and the phone is not aware of the softswitch(es).
Either the softswitch(es) host name(s) or IP address(es) must be programmed in the system, enabling
communication between the two. All phones must use the same softswitch or set of softswitches, and the
phone must send all requests to the destination IP address of the AOS device. In Stateful Proxy mode, the
softswitch address configured in the phone is the proxy (AOS device), and SIP signaling is sent to the
Layer 3 destination address of the proxy (AOS device).
Stateful Proxy Mode Basic Configuration
ip sip
ip sip proxy
ip sip proxy sip-server primary <IP Address>
Outbound Proxy Mode
In the Outbound Proxy mode, the ADTRAN device’s duties may include numerous functions, such as
establishing the service provider's boundaries, receiving and sending Voice over Internet Protocol (VoIP)
traffic behind a firewall, controlling network call routing, and network quality of service (QoS). The
system may not require configuration to be aware of the softswitch. The softswitch (which can be B2BUA
or Stateful Proxy) takes on the role as the server and registrar in this mode. Requests sent from the phones
are routed to the destination IP address of the softswitch. The lack of configuration is usually not an issue
because the SIP messages contain the necessary routing information. The softswitch address configured in
the phone is the external softswitch, and SIP signaling is sent to the Layer 3 destination address of the
proxy.
Outbound Proxy Mode Basic Configuration
ip sip
ip sip proxy
Your configuration most closely matches Outbound Proxy mode. However, this is used rarely and requires that phone insert the softswitch IP address in the SIP message headers, but that the layer 3 destination IP address be the Adtran unit. If the output of "show sip proxy user" has an entry for each of your phones and you feel confident you are configured for the proper mode, we will likely need you to open a regular Technical Support ticket by calling 888-423-8726 or sending an email to support@adtran.com so that we can troubleshoot directly on the unit.
Thanks!
David
Meyerj66,
Thanks for posting. Are you setup using the Polycom phones in a B2BUA mode (one voice user per phone) or in SIP proxy mode? In either case, we should be able to fail over, but it will change the debug commands we sue. We will likely need to see your configuration and the output of the following debug commands for a test call.
debug sip stack message
debug voice verbose
debug sip proxy verbose
Please make sure that your configuration and debug output file do not contain any sensitive information such as IP addresses or phone numbers that you do not want to make public. You might be able to use a find/replace to get those items of your files. Otherwise, we will need you to create a regular support ticket by calling 888-423-8726 or emailing support@adtran.com with those files and an explanation of the problem.
Thanks!
David
Phones are in SIP Proxy mode. Like I said earlier when the WAN is off line ext. to ext. will not work.
sh run
Building configuration...
!
!
! ADTRAN, Inc. OS version A4.07.00.E
! Boot ROM version 14.05.00.SA
! Platform: Total Access 908e (2nd Gen), part number 4242908L1
! Serial number CFG0744327
!
!
hostname "ABC Company"
enable password md5 encrypted 3f8c6bdd18aca3fe20277c0434cd461e
!
!
ip subnet-zero
ip classless
ip default-gateway X.X.X.X
ip routing
!
!
ip domain-proxy
ip name-server X.X.X.X
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
service password-encryption
!
username "jmeyer" password encrypted "3d3587c6e9409261046db48a8a1f24e4a871"
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
ip dhcp-server pool "Phones"
network 10.20.10.0 255.255.255.0
dns-server X.X.X.X X.X.X.X
netbios-node-type h-node
default-router 10.20.10.1
lease 0 4 0
option 2 hex 0xFFFFB9B0
option 66 ascii "ftp://demojoe:gptw333@abc.company.comgptw333@abc.company.com"
option 42 ip X.X.X.X
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address dhcp
media-gateway ip primary
no shutdown
!
!
interface eth 0/2
speed 100
encapsulation 802.1q
no shutdown
!
interface eth 0/2.1
vlan-id 1 native
ip address 192.168.1.1 255.255.255.0
access-policy Private
media-gateway ip primary
no shutdown
interface eth 0/2.10
vlan-id 10
ip address 10.20.10.1 255.255.255.0
access-policy Private
media-gateway ip primary
no shutdown
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
!
interface fxo 0/0
shutdown
!
!
!
!
!
!
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended self
remark Traffic to Total Access
permit ip any any log
!
ip access-list extended wizard-pfwd-1
remark Port Forward 1
permit tcp any host X.X.X.X log
!
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface eth 0/1 overload
!
ip policy-class Public
nat destination list wizard-pfwd-1 address 192.168.1.254
!
!
!
ip route 0.0.0.0 0.0.0.0 X.X.X.X
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
!
!
!
voice codec-list G711
default
codec g711ulaw
!
!
!
voice trunk T01 type sip
sip-server primary X.X.X.X
registrar primary X.X.X.X
codec-group G711
!
!
voice grouped-trunk SIP
trunk T01
accept $ cost 0
!
!
!
!
!
!
!
!
!
!
!
!
!
ip sip proxy
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
login local-userlist
line-timeout 90
!
line telnet 0 4
login local-userlist
line-timeout 60
shutdown
line ssh 0 4
login local-userlist
line-timeout 60
no shutdown
!
!
!
!
!
end
ABC Company#
Meyerj66,
Thanks for getting us your configuration. Does your unit show SIP proxy users when you issue the "show sip proxy user" command? If not, we may not be configured for the correct SIP proxy mode. Below are the mode descriptions and the corresponding SIP proxy configuration. The configuration samples omit basic interface, firewall settings, etc. for the sake of brevity. More complete examples can be found in Configuring SIP Proxy in AOS.
Transparent Proxy Mode
The Transparent Proxy mode is best for new installations when the phone does not need to be aware of the
device presence (transparency). In this mode, the softswitch is configured as the server and the registrar
(and Outbound Proxy when required). The phones are not aware of the AOS device, and phones are not
required to use the same softswitch. Requests sent from the phones are routed to the destination IP address
of the softswitch, and the AOS device does not require configuration to be aware of the softswitch. In
Transparent Proxy mode, the softswitch address configured in the phone is the external softswitch, and SIP
signaling is sent to the Layer 3 destination address of the external softswitch.
Transparent Proxy Mode Basic Configuration
ip sip
ip sip proxy
ip sip proxy transparent
Stateful Proxy Mode
The Stateful Proxy mode is best suited for existing installations due to the ease of converting from B2BUA
to IP phones without modifying the phone configurations. In this mode, phones or user agents (UAs) rely
on the SIP server to act as the proxy, and the configuration is very similar to the existing B2BUA. The
AOS product takes on the role of proxy. The UA is not aware of other SIP servers on the network in this
mode. Each phone is configured to register to the proxy, and the phone is not aware of the softswitch(es).
Either the softswitch(es) host name(s) or IP address(es) must be programmed in the system, enabling
communication between the two. All phones must use the same softswitch or set of softswitches, and the
phone must send all requests to the destination IP address of the AOS device. In Stateful Proxy mode, the
softswitch address configured in the phone is the proxy (AOS device), and SIP signaling is sent to the
Layer 3 destination address of the proxy (AOS device).
Stateful Proxy Mode Basic Configuration
ip sip
ip sip proxy
ip sip proxy sip-server primary <IP Address>
Outbound Proxy Mode
In the Outbound Proxy mode, the ADTRAN device’s duties may include numerous functions, such as
establishing the service provider's boundaries, receiving and sending Voice over Internet Protocol (VoIP)
traffic behind a firewall, controlling network call routing, and network quality of service (QoS). The
system may not require configuration to be aware of the softswitch. The softswitch (which can be B2BUA
or Stateful Proxy) takes on the role as the server and registrar in this mode. Requests sent from the phones
are routed to the destination IP address of the softswitch. The lack of configuration is usually not an issue
because the SIP messages contain the necessary routing information. The softswitch address configured in
the phone is the external softswitch, and SIP signaling is sent to the Layer 3 destination address of the
proxy.
Outbound Proxy Mode Basic Configuration
ip sip
ip sip proxy
Your configuration most closely matches Outbound Proxy mode. However, this is used rarely and requires that phone insert the softswitch IP address in the SIP message headers, but that the layer 3 destination IP address be the Adtran unit. If the output of "show sip proxy user" has an entry for each of your phones and you feel confident you are configured for the proper mode, we will likely need you to open a regular Technical Support ticket by calling 888-423-8726 or sending an email to support@adtran.com so that we can troubleshoot directly on the unit.
Thanks!
David
Meyerj66,
I went ahead and flagged this post as "Assumed Answered". If any of the responses on this thread assisted you, please mark them as Correct or Helpful as the case may be with the applicable buttons. This will make them visible and help other members of the community find solutions more easily. If you still need assistance, I would be more than happy to continue working with you on this - just let me know in a reply.
Thanks!
David
hello
plz i would to add note here
how i can disable password encrypt from my ADTRAN Total Access 908e
or dencrypted my encryptd password
If you dont want to encrypt your password use the following:
enable password password
username "admin" password "password"
As for decrypting a password I don't think the Adtran does that.
please can you explain this for me
step by step how to disable password encryptd on ADTRAN Total Access 908e
Please post your config (remove any sensitive data) and I will show you which lines to change.
yahya,
Thanks for posting! Since the encryption is a one-way hash, it really is not possible to decrypt it within the Adtran. You will need to overwrite and/or shut off the feature. To overwrite, you will just need to enter your password commands again with the password you choose. To turn off the feature, you will need to enter "no service password-encryption" and then reenter each password. Below is an example.
TA900#conf t
TA900(config)#no service password-encryption
TA900(config)#enable password adtran
TA900(config)#username admin password adtran
etc.
Thanks!
David
Meyerj66,
I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.
Thanks,
David