I have the following config on an Adtran 908e 2nd Gen. The failover kicks in when the eth 0/1 is unplugged but if I remove the modem's coax on the primary. The Failover bounces. Any changes to the config below to prevent this.
ip local policy route-map probe ping1
probe ping1 icmp-echo
destination 8.8.8.8
period 10
tolerance consecutive fail 6 pass 3
no shutdown
!
!
track ping1
snmp trap state-change
test list or
if probe ping1
no shutdown
!
interface eth 0/1
ip address x.x.x.x x.x.x.x (Primary WAN)
no shutdown
media-gateway ip primary
!
interface eth 0/2
ip address x.x.x.x x.x.x.x (Back up WAN
no awcp
no shutdown
media-gateway ip primary
route-map probeping1 permit 10
match ip address ping1
set ip next-hop x.x.x.x (Primary Gateway)
set interface null 0
ip route 0.0.0.0 0.0.0.0 x.x.x.x (Primary Gateway) track ping1
ip route 0.0.0.0 0.0.0.0 x.x.x.x (Back Up Gateway) 10
After talking to Adtran, I found that the track FFAILOVER missing from the primary route:
ip route 0.0.0.0 0.0.0.0 x.x.x.x (Primary IP Gateway) track FAILOVER
When tested by removing the coax cable from the modem it worked.
Correct Config below:
ip access-list extended MATCHALL-FAILOVER
permit ip any any
exit
!
no ip policy-class WAN-FAILOVER rpf-check
ip policy-class WAN-FAILOVER
allow list MATCHALL-FAILOVER self
allow list MATCHALL-FAILOVER stateless
exit
!
interface eth 0/1
ip address x.x.x.x x.x.x.x (Primary IP and Mask)
no awcp
no shutdown
no lldp send-and-receive
media-gateway ip primary
!
! -- Fail over Interface
!
interface eth 0/2
ip address x.x.x.x x.x.x.x (Back up IP and Mask)
ip access-policy WAN-FAILOVER
media-gateway ip primary
no shutdown
exit
!
!
probe FAILOVER icmp-echo
destination 4.2.2.2
source-address x.x.x.x (Back up IP Gateway)
period 2
tolerance consecutive fail 3 pass 3
no shutdown
exit
!
track FAILOVER
snmp trap state-change
test if probe FAILOVER
no shutdown
exit
!
!
!
!
ip access-list extended pingprobe
permit icmp host x.x.x.x (Primary IP) host 4.2.2.2
exit
!
ip local policy route-map ICMP_FAILOVER
!
route-map ICMP_FAILOVER permit 10
match ip address pingprobe
set ip next-hop x.x.x.x (Primary IP Gateway)
set interface null 0
exit
!
ip route 0.0.0.0 0.0.0.0 1x.x.x.x (Back up IP Gateway) 250
ip route 0.0.0.0 0.0.0.0 x.x.x.x (Primary IP Gateway) track FAILOVER
I tried with the following config too and same issue the failover kicks in only when disconnecting eth 0/1.
ip access-list extended MATCHALL-FAILOVER
permit ip any any
exit
!
no ip policy-class WAN-FAILOVER rpf-check
ip policy-class WAN-FAILOVER
allow list MATCHALL-FAILOVER self
allow list MATCHALL-FAILOVER stateless
exit
!
interface eth 0/1
ip address x.x.x.x x.x.x.x (Primary IP and Mask)
no awcp
no shutdown
no lldp send-and-receive
media-gateway ip primary
!
! -- Fail over Interface
!
interface eth 0/2
ip address x.x.x.x x.x.x.x (Back up IP and Mask)
ip access-policy WAN-FAILOVER
media-gateway ip primary
no shutdown
exit
!
!
probe FAILOVER icmp-echo
destination 8.8.8.8
source-address x.x.x.x (Back up IP Gateway)
period 10
tolerance consecutive fail 5 pass 10
no shutdown
exit
!
track FAILOVER
snmp trap state-change
test if probe FAILOVER
no shutdown
exit
!
!
!
!
ip access-list extended pingprobe
permit icmp host x.x.x.x (Primary IP) host 8.8.8.8
exit
!
ip local policy route-map ICMP_FAILOVER
!
route-map ICMP_FAILOVER permit 10
match ip address pingprobe
set ip next-hop x.x.x.x (Primary IP Gateway)
set interface null 0
exit
!
ip route 0.0.0.0 0.0.0.0 1x.x.x.x (Back up IP Gateway) 250
ip route 0.0.0.0 0.0.0.0 x.x.x.x (Primary IP Gateway)
Because the interface doesn't physically go down on the 908 when you unplug the coax on the modem (the ethernet link between modem and 908 is still active), the 908 still thinks it is active. You would probably need to setup a probe test on that 908 that is continually sending pings to a destination. When that ping test fails, and your defined thresholds have been exceeded, the 908 would then fail traffic over to the other interface. See if the following helps you: https://supportcommunity.adtran.com/t5/General/Configuring-Network-Monitor-in-AOS/ta-p/28369
Jeff
After talking to Adtran, I found that the track FFAILOVER missing from the primary route:
ip route 0.0.0.0 0.0.0.0 x.x.x.x (Primary IP Gateway) track FAILOVER
When tested by removing the coax cable from the modem it worked.
Correct Config below:
ip access-list extended MATCHALL-FAILOVER
permit ip any any
exit
!
no ip policy-class WAN-FAILOVER rpf-check
ip policy-class WAN-FAILOVER
allow list MATCHALL-FAILOVER self
allow list MATCHALL-FAILOVER stateless
exit
!
interface eth 0/1
ip address x.x.x.x x.x.x.x (Primary IP and Mask)
no awcp
no shutdown
no lldp send-and-receive
media-gateway ip primary
!
! -- Fail over Interface
!
interface eth 0/2
ip address x.x.x.x x.x.x.x (Back up IP and Mask)
ip access-policy WAN-FAILOVER
media-gateway ip primary
no shutdown
exit
!
!
probe FAILOVER icmp-echo
destination 4.2.2.2
source-address x.x.x.x (Back up IP Gateway)
period 2
tolerance consecutive fail 3 pass 3
no shutdown
exit
!
track FAILOVER
snmp trap state-change
test if probe FAILOVER
no shutdown
exit
!
!
!
!
ip access-list extended pingprobe
permit icmp host x.x.x.x (Primary IP) host 4.2.2.2
exit
!
ip local policy route-map ICMP_FAILOVER
!
route-map ICMP_FAILOVER permit 10
match ip address pingprobe
set ip next-hop x.x.x.x (Primary IP Gateway)
set interface null 0
exit
!
ip route 0.0.0.0 0.0.0.0 1x.x.x.x (Back up IP Gateway) 250
ip route 0.0.0.0 0.0.0.0 x.x.x.x (Primary IP Gateway) track FAILOVER