Currently have a customer that can only receive a 10 digit caller id on their phones display. Is there a way to strip the "1" off of the 11 digit caller id that comes in to them?
yes, the adtran can do that. Can you explain your configuration. Is this a SIP to PRI configuration?
If possible post your config and remove any passwords.
Thanks,
Mark
Mark,
Here is a config we have currently for a customer that can only receive 10 digits for caller id to show up on their phone displays.
hostname "##-###-###-adt924e-####"
enable password ########
clock timezone -6-Central-Time
ip subnet-zero
ip classless
ip routing
ip domain-name "#######.net"
ip name-server 0.0.0.0 0.0.0.0
no auto-config
event-history on
no logging forwarding
no logging email
service password-encryption
username "####" password #######
no ip firewall alg msn
no ip firewall alg h323
no dot11ap access-point-control
interface eth 0/1
ip address 0.0.0.0 0.0.0.0
media-gateway ip primary
no shutdown
exit
interface eth 0/2
no ip address
shutdown
exit
interface t1 0/1
shutdown
exit
interface t1 0/2
shutdown
exit
interface t1 0/3
shutdown
exit
interface t1 0/4
shutdown
exit
interface fxs 0/1
no shutdown
exit
interface fxs 0/2
no shutdown
exit
interface fxs 0/3
no shutdown
exit
interface fxs 0/4
no shutdown
exit
interface fxs 0/5
no shutdown
exit
interface fxs 0/6
no shutdown
exit
interface fxs 0/7
no shutdown
exit
interface fxs 0/8
no shutdown
exit
interface fxs 0/9
shutdown
exit
interface fxs 0/10
shutdown
exit
interface fxs 0/11
shutdown
exit
interface fxs 0/12
shutdown
exit
interface fxs 0/13
shutdown
exit
interface fxs 0/14
shutdown
exit
interface fxs 0/15
shutdown
exit
interface fxs 0/16
shutdown
exit
interface fxs 0/17
shutdown
exit
interface fxs 0/18
shutdown
exit
interface fxs 0/19
shutdown
exit
interface fxs 0/20
shutdown
exit
interface fxs 0/21
shutdown
exit
interface fxs 0/22
shutdown
exit
interface fxs 0/23
shutdown
exit
interface fxs 0/24
shutdown
exit
interface fxo 0/0
shutdown
exit
ip access-list standard mgmt
permit host 0.0.0.0
permit host 0.0.0.0
exit
ip access-list standard monitoring
permit host 0.0.0.0
permit 0.0.0.0 0.0.0.0
exit
ip route 0.0.0.0 0.0.0.0 0.0.0.0
no ip tftp server
no ip tftp server overwrite
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
snmp-server contact "domain@########.net"
snmp-server location "------ ----- ------- -----"
snmp-server community ###### RO monitoring
voice feature-mode network
voice forward-mode network
voice codec-list fxsports
codec g711ulaw
exit
voice trunk T01 type sip
description "Trunk for FXS ports"
match dnis "NXX-XXXX" substitute "1-402-NXX-XXXX"
match dnis "NXX-NXX-XXXX" substitute "1-NXX-NXX-XXXX"
sip-server primary sbcrtp.p2.#######.com udp 5065
registrar primary sbcrtp.p2.#######.com udp 5065
domain "sbcrtp.p2.#######.com"
codec-group fxsports
default-ring-cadence internal
exit
voice grouped-trunk MAIN
no description
trunk T01
accept $ cost 0
exit
voice user 1234567890
connect fxs 0/1
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_01" password
sip-authentication password
codec-group fxsports
exit
voice user 1234567890
connect fxs 0/2
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_02" password
sip-authentication password
codec-group fxsports
exit
voice user 1234567890
connect fxs 0/3
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_03" password
sip-authentication password
codec-group fxsports
exit
voice user 1234567890
connect fxs 0/4
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_04" password
sip-authentication password
codec-group fxsports
exit
voice user 1234567890
connect fxs 0/5
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_05" password
sip-authentication password
codec-group fxsports
exit
voice user 1234567890
connect fxs 0/6
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_06" password
sip-authentication password
codec-group fxsports
exit
voice user 1234567890
connect fxs 0/7
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_07" password
sip-authentication password
codec-group fxsports
exit
voice user 1234567890
connect fxs 0/8
password encrypted "1a1e5b71ee92b5ed6304ce4748ac1c824558"
caller-id-override external-number 1234567890
sip-identity 1234567890 T01 register auth-name "####_fxs_08" password
sip-authentication password
codec-group fxsports
exit
ip sip
ip sip authenticate
line con 0
no login
exit
line telnet 0 4
login
shutdown
exit
line ssh 0 4
login local-userlist
no shutdown
access-class mgmt in
exit
Cory,
Sorry but unfortunately with FXS ports we can only send out what we get from the SIP Server that is providing your SIP trunk. You will need to contact your provider and ask them to modify it. Most providers only send 10 digits in the SIP INVITE.
To verify, you can run "debug sip stack messages" and then place an inbound call.
Sorry that we weren't able to come to a resolution for you.
-Mark