cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AVNECLD
New Contributor

if a number is dialed that legitimately fails it keeps trying all the other endpoints / pbxs /faxs

solicited below are two devices one is an ip office one is a fax server.  if a call goes out on the ip office (172.16.99.41) and it is to a legitimately failed number the SBC keeps trying until it dials the fax server (in this case voice grouped-trunk 172.17.99.11) instead of passing along a busy signal etc.

“NV3148PRIMARY”#show run
Building configuration...
!
!
! ADTRAN, Inc. OS version R13.10.1.HB

!
!
hostname "“NV3148PRIMARY”"
enable password level 2
enable password
!
!
clock timezone -6-Central-Time
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
!
domain-proxy
name-server 8.8.8.8
!
!
auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password ""
username "avo" privilege 7 password ""
!
banner motd #
****** Important Banner Message ******

Enable and Telnet passwords are configured to "password".
SSH, HTTP, and HTTPS default username is "admin" and password is "password".
Please change them immediately.

The gigabit-ethernet 0/1 interface is enabled with an address of 10.10.10.1
Telnet, SSH, HTTP, and HTTPS access are also enabled.
To remove this message, while in configuration mode type "no banner motd".

****** Important Banner Message ******


#
!
!
ip firewall
ip firewall stealth
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
aaa on
ftp authentication LoginUseLocalUsers
!
!
aaa authentication login LoginUseTacacs group tacacs+
aaa authentication login LoginUseRadius group radius
aaa authentication login LoginUseLocalUsers local
aaa authentication login LoginUseLinePass line
!
aaa authentication enable default enable
!
aaa authentication port-auth default local
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
vlan 1
name "Default"
!
!
interface gigabit-eth 0/1
ip address 2.2.2.2 255.255.255.0
ip address 10.10.10.1 255.255.255.0 secondary
no shutdown
media-gateway ip primary
!
!
interface gigabit-eth 0/2
no ip address
shutdown
!
!
interface gigabit-eth 0/3
no ip address
shutdown
!
!
interface gigabit-eth 0/4
ip address 172.17.xx.xxx 255.255.255.0
no shutdown
media-gateway ip primary
!
!
!
interface gigabit-switchport 0/1
no shutdown
!
interface gigabit-switchport 0/2
no shutdown
!
interface gigabit-switchport 0/3
no shutdown
!
interface gigabit-switchport 0/4
no shutdown
!
interface gigabit-switchport 0/5
no shutdown
!
interface gigabit-switchport 0/6
no shutdown
!
interface gigabit-switchport 0/7
no shutdown
!
interface gigabit-switchport 0/8
no shutdown
!
!
!
!
!
!
ip access-list standard sip-access-list
permit host 67.212.xx.xx

!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 38.83.xx.xx
!
no tftp server
no tftp server overwrite
http authentication LoginUseLocalUsers
no http server
no http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
snmp-server engine local 800000000000
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
voice international-prefix abbreviated
!
voice feature-mode network
voice flashhook mode transparent
voice transfer-mode local
voice forward-mode network
!
!
!
!
!
!
!
!
voice dial-plan 2 long-distance 1-NXX-NXX-XXXX
voice dial-plan 3 local NXX-NXX-XXXX
!
!
!
!
!
voice trunk T01 type sip
description "twillio"
match dnis "$" substitute "0111$"
match ani "$" substitute "0111$" name "INCOMING CALL"
sip-server primary bleh.pstn.ashburn.twilio.com
sip-server secondary bleh.pstn.umatilla.twilio.com
sip-header-passthrough both
!
voice trunk T03 type sip
description "twillio"
sip-server primary bleh.pstn.ashburn.twilio.com
sip-header-passthrough both
!
voice trunk T11 type sip
match dnis "1$" substitute "$"
sip-server primary 172.17.99.11
trust-domain
grammar from host local
transfer-mode network
!
voice trunk T41 type sip
match dnis "1$" substitute "$"
sip-server primary 172.17.99.41
sip-header-passthrough both
trust-domain
grammar from host local
transfer-mode network
!

voice grouped-trunk 172.17.99.41
trunk T01
trunk T41
trunk T03
accept $ cost 0
accept xxx-575-36xx cost 0
!
!
voice grouped-trunk 172.17.99.11
trunk T01
trunk T11
trunk T03
accept $ cost 0
accept xxx-277-65xx cost 0
accept xxx-277-65xx cost 0
accept xxx-277-65xx cost 0
accept xxx-277-65xx cost 0

!
!
!
!
!
!
!
!
sip privacy
!
sip access-class ip "sip-access-list" in
!
!
!
!
!
!
!
!
!
!
no sip prefer double-reinvite
!
!
sip grammar from user international
!
!
!
!
ip rtp media-anchoring
!
!
line con 0
login authentication LoginUseLinePass
password A
!
line telnet 0 4
login authentication LoginUseLinePass
password A
shutdown
line ssh 0 4
login authentication LoginUseLocalUsers
no shutdown
!
!
ntp server 172.17.99.1 source gigabit-ethernet 0/4
!
!
!
!
!
end
“NV3148PRIMARY”#
“NV3148PRIMARY”#
“NV3148PRIMARY”#
“NV3148PRIMARY”#
“NV3148PRIMARY”#
“NV3148PRIMARY”#
“NV3148PRIMARY”#
“NV3148PRIMARY”#
“NV3148P

0 Kudos
1 Reply
AVNECLD
New Contributor

Re: if a number is dialed that legitimately fails it keeps trying all the other endpoints / pbxs /fa

looks like this is the answer as it is working so far, I have not seen anyone on here with this many voice applications / avaya servers, fax servers, asterisk etc behind a single SBC but anyway this looks like this is it 

create lists for each PBX / Fax Server etc

voice trunk-list 99.11
trunk T01
trunk T03
trunk T11
!
voice trunk-list 99.41
trunk T01
trunk T03
trunk T41

then in each one of the grouped trunks do the following, you have to have each list for each group added otherwise it will still keep trying other PBXs, fax servers etc and you will get a lot of complaints from people who are simply trying to dial a wrong number

voice grouped-trunk 172.17.99.41
trunk T01
trunk T41
trunk T03
accept $ cost 0
accept xxx-xxx-xxx cost 0
permit list 99.41
!deny all other trunks
!deny all other ani

 

voice grouped-trunk 172.17.99.11
trunk T01
trunk T11
trunk T03
accept $ cost 0
accept xxx-xxx-xxxx cost 0
permit list 99.11
!deny all other trunks
!deny all other ani

so in other words every single ip pbx fax server asterisk or whatever is behind the netvanta 3148 / 908e etc will have to have a permit listing so it doesn't keep trying all of the devices in your list