I have an Edge stack of 7 1638ps and a Core stack of 2 1638s. In addition to the ActivChassis stacking modules and cables for each switch, I have stacking modules in both Core switches and VCIDs 3 and 7 in the Edge stack, cabled as:
Core 1/2/1 => Edge 3/2/1
Core 1/2/2 => Edge 3/2/2
Core 2/2/1 => Edge 7/2/1
Core 2/2/2 => Edge 7/2/2
this gives me these results:
Core 1/2/1 => Edge 3/2/1 >>> 1Gb/s, data flowing (web interface shows 1000/Full on Core, 1000/Full on EDGE)
Core 1/2/2 => Edge 3/2/2 >>> 10Gb/s, all packets discarded (web interface shows 10G/ActivChassis on Core, 10G/Full on EDGE)
Core 2/2/1 => Edge 7/2/1 >>> 10Gb/s, all packets discarded (web interface shows 10G/ActivChassis on Core, 10G/Full on EDGE)
Core 2/2/2 => Edge 7/2/2 >>> 10Gb/s, all packets discarded (web interface shows 10G/ActivChassis on Core, 10G/Full on EDGE)
Snippets of the web interface attached.
Could be the web interface just has a display bug but the fact is that no data is flowing on three of the four ports. I don't know how long the switches have been in this state. I discovered this after parts of the EDGE stack crashed twice in 5 days and I was carefully reviewing the configs. I have no idea if this would cause a crash, but it certainly looks like something that ought to get fixed.
For now I have created a LAG with 4 gigabit ports and shut the 10Gb interfaces down.
I have a feeling that rebooting the Core switches will clear this up, but that's a non-trivial thing to do and I am looking for some thoughts on whether that will actually help, or if there is another solution.
Thanks.
Config is as follows:
AOS R11.10.5 on both stacks
CORE:
interface port-channel 1
description (port-channel 1) LAG to EDGE
spanning-tree port-priority 64
no shutdown
switchport mode trunk
interface xgigabit-switchport 1/2/1
description (1/2/1) CORE-EDGE LAG-1
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto
interface xgigabit-switchport 1/2/2
description (1/2/2) CORE-EDGE LAG-2
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto
interface xgigabit-switchport 2/2/1
description (2/2/1) CORE-EDGE LAG-3
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto
interface xgigabit-switchport 2/2/2
description (2/2/2) CORE-EDGE LAG-4
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto
EDGE:
interface port-channel 1
description (port-channel 1) LAG to CORE
spanning-tree port-priority 64
no shutdown
switchport mode trunk
interface xgigabit-switchport 3/2/1
description (3/2/1) CORE-EDGE LAG-1
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto
interface xgigabit-switchport 3/2/2
description (3/2/2) CORE-EDGE LAG-2
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto
interface xgigabit-switchport 7/2/1
description (7/2/1) CORE-EDGE LAG-3
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto
interface xgigabit-switchport 7/2/2
description (7/2/2) CORE-EDGE LAG-4
shutdown
switchport mode trunk
channel-group 1 mode on
speed auto