Configuring Frame-Relay in AOS Quick Start Guide
Frame-Relay is a Layer 2 protocol that facilitates data communications over T1, E1, DDS and Serial interfaces. Frame-Relay allows multiple paths of link layer communications over a single link.
Requirements
This guide assumes the T1 or E1 interface has already been configured and is ‘Up’. For more information about configuring T1 or E1 interfaces consult the guide titled “Configuring T1 and E1 Interfaces in AOS”.
Software Requirements
Hardware Requirements
Information Requirements
Configuring in the Web Interface
1) Click “Physical Interfaces”
2) Click on the interface that will transport Frame-Relay. (Example: T1 1/1)
3) Set the “Encapsulation Mode” to “Frame-Relay”.
4) Click Apply.
5) Set the “Link Management Protocol” (LMI Type) to “Auto”.
6) Set the “Interface Type” to “Connect to a Switch..”
7) Click Apply.
😎 Under “Configured Permanent Virtual Circuit”, click “Add”.
9) Enter the Appropriate “DLCI Number”.
10) Under “IP Settings”, set “Address Type” to “Static”.
11) Enter the appropriate IP Address and Subnet Mask.
12) Click “Apply”
The Status of the Frame-Relay and Frame-Relay Sub-Interfaces are available at the bottom of the Frame-Relay and Frame-Relay Sub-Interfaces configuration pages.
Configuring in the Command Line Interface
Access the Command Line via the Console Port or Telnet. The following commands will configure a Frame-Relay interface over a T1 or E1 interface.
1) Enter enabled mode and enter the enable password if prompted.
a. Syntax: enable
b. Hostname> enable
2) Enter Global Configuration mode.
a. Syntax: configure terminal
b. Hostname#: configure terminal
3) Create the Frame-Relay interface with a unique identifying number.
a. Syntax: interface fr <number>
b. Hostname(config)#: interface fr 1
4) Cross-connect the Frame interface with a Layer 1 interface (T1 and Serial shown)
a. Syntax: cross-connect <number> <interface> <slot/port> [<tdm-group number] fr <fr number>
b. Hostname(config-fr 1)#: cross-connect 1 t1 1/1 9 fr 1
c. Hostname(config-fr 1)#: cross-connect 1 ser 1/1 9 fr 1
5) Enable the Frame-Relay Interface
a. Syntax: no shutdown
b. Hostname(config-fr 1)#: no shutdown
6) Exit the Frame-Relay Interface.
a. Syntax: exit
b. Hostname(config-fr 1)#: exit
7) Create the Frame-Relay Sub-Interface with a unique identifying number.
a. Syntax: interface fr <number.sub-number>
b. Hostname(config)#: interface fr 1.1
😎 Assign the Frame-Relay Sub-Interface an IP Address.
a. Syntax: ip address <A.B.C.D> <subnetmask | /prefix-length>
b. Hostname(config-fr 1.1)#: ip address 192.168.0.1 255.255.255.0
9) Assign the Frame-Relay Sub-Interface a DLCI Number.
a. Syntax: frame-relay interface-dlci <DLCI-Number>
b. Hostname(config-fr 1.1)#: frame-relay interface-dlci 16
10) Enable the Frame-Relay Sub interface.
a. Syntax: no shutdown
b. Hostname(config-fr 1.1)#: no shutdown
11) View the status of the Frame-Relay Interface.
a. Syntax: do show interface fr <fr number>
b. Hostname(config-fr 1)#: do show interface fr 1
12) View the status of the Frame-Relay Sub-Interface.
a. Syntax: do show interface fr <fr number.sub-number>
b. Hostname(config-fr 1.1)#: do show interface fr 1.1
Example Configurations
T1 Interface:
interface t1 1/1
tdm-group 9 timeslots 1-24 speed 64
no shutdown
!
interface fr 1
cross-connect 1 t1 1/1 9 fr 1
no shutdown
!
interface fr 1.1
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 16
no shutdown
E1 Interface:
interface e1 1/1
tdm-group 9 timeslots 1-31 speed 64
no shutdown
!
interface fr 1
cross-connect 1 t1 1/1 9 fr 1
no shutdown
!
interface fr 1.1
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 16
no shutdown
DDS Interface:
interface dds 1/1
no shutdown
!
interface fr 1
cross-connect 1 dds 1/1 fr 1
no shutdown
!
interface fr 1.1
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 16
no shutdown
Serial Interface:
interface serial 1/1
no shutdown
!
interface fr 1
cross-connect 1 serial 1/1 fr 1
no shutdown
!
interface fr 1.1
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 16
no shutdown